0

I'm an inkscape newbie. On my desktop I have Inkscape. I draw a line and then can go to the strokewidth property and change the width.

However, I have the same program (same version) installed on my laptop and I do exactly the same and the lines are always fixed at about 2.14mm. I change the strokewidth field up and down and it doesn't affect the strokewidth.

I pulled a file from my desktop down with a line at .5mm, which showed up correctly on my laptop. So I selected the line (width 0.565mm as shown in the strokewidth) and went to Preferences and clicked "Take from selection" and it took 2.14mm rather than the selected line's 0.565mm,

In this picture you can see the thin line selected, and the thicker line I am getting, and the two different stroke widths (this is just after I clicked "Take From Selection".

This only happens on my laptop. I tried with both a pen and a simple mouse cursor and got the same problem.

I am baffled as to what I am doing wrong. enter image description here

After this set up, I select the pencil tool and draw another line, which I have set to red below, and as you see it didn't change the line width. I went in to the strokewidth and set it smaller and smaller until it got to zero, and the stroke width didn't change.

enter image description here

5
  • Hi. Welcome to GDSE. The unit shown in yellow in the Preferences is not in mm. In the preferences the measurement unit is pixels (rounded up to two decimal places). 0.565mm = 2.135px (rounded up to 2.14px). To change the size of the stroke, you must first select the object, then you can change its width in the Stroke Style dialog. In your screenshot, you seem to have selected another object which is partially hidden by the preferences dialog.
    – Billy Kerr
    Commented Apr 12, 2023 at 23:18
  • @BillyKerr Thanks for your comment, I added more in my question. After the picture you saw I immediately drew another line and it was still thick. When I selected that line and tried to reduce the stroke width, it didn't reduce. This only seems to happen on my laptop (but I need to do this on my laptop so I can use a pen to draw with.) I'm a bit at my wits end with this.
    – Fraser Orr
    Commented Apr 13, 2023 at 1:39
  • Hmmm . . . looks like you might have the Pressure Input selected on in the Pencil Tool control options. That will add effects to your path which are overriding the stroke style. Disable it The location is shown here.
    – Billy Kerr
    Commented Apr 13, 2023 at 1:47
  • Thanks so much!! That was exactly the problem. If you want to answer the question I'll accept so that other newbies like me don't get caught in this.... Again, I've been banging my head against a wall on this, so I really appreciate your help.
    – Fraser Orr
    Commented Apr 13, 2023 at 1:51
  • Oh great! Glad that worked for you. I've added an answer now.
    – Billy Kerr
    Commented Apr 13, 2023 at 9:51

1 Answer 1

1

It's because you have the Pressure Input option selected in the Control Bar for the Freehand (Pencil) Tool P. This will add path effects which are overriding the stroke width you are trying to set. This setting can be used for variable strokes* when using a pressure sensitive graphics tablet, but if you are not using one or if you just want a simple stroke, then best not to use this option.

Just disable it, shown here

enter image description here

A little tip that might help newbies troubleshoot unexpected problems like this is to open up the Path Effects panel using Ctrl+&. Select an object, then if you see path effects listed, these could be the issue. You can also delete and add path effects in this panel using the + and - buttons.

enter image description here

*Note: The PowerStroke effect which is added when you use the Input Pressure option discussed above can be very useful even if you don't use a pressure sensitive graphics tablet. It's possible to edit the effect on-screen to create variable strokes manually. You can Ctrl+click the pink width control point to add more control points and change their position.

An example

enter image description here

1
  • Really useful additional info.
    – Fraser Orr
    Commented Apr 13, 2023 at 21:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.