1

Running Adobe InDesign 18.3 via Creative Cloud 5.10.0 in MacOS Ventura 13.4.

Once a file is closed in InDesign a new window opens with a 'welcome' salutation and displaying links to recent files, templates, etc. How can this 'welcome' screen be disabled or turned off? I have looked in preferences for a checkbox to toggle but there is none.

Thank you, Pete

2
  • Isn't there a checkbox on the welcome screen?
    – Scott
    Commented Jun 6, 2023 at 16:59
  • Nope. If it helps I can post a screen. Commented Jun 7, 2023 at 6:11

1 Answer 1

2

All you need is to uncheck the checkbox 'Show Home Screen When No Documents Are Open' in the Preferences > General:

enter image description here

But there is the glitch and the checkbox can be grayed out. So it can not be changed via the interface. You need a script to uncheck it.

Try this trick.

  1. Go to the folder ~/Library/Preferences/Adobe InDesign/Version 17.0/en_US/Scripts/

  2. Create the folder Startup there

  3. Inside the folder create the file hide_home_screen.applescript that contain:

tell application "Adobe InDesign 2022"
    set show whats new on startup of general preferences to false
    set show start workspace of general preferences to false
    set GG to properties of general preferences
end tell
  1. Save the file and restart InDesign.

Perhaps in your case you have to change /Version 17.0/ to /Version 18.0/ and "Adobe InDesign 2022" to "Adobe InDesign 2023".

The script unchecks automatically the checkbox 'Show Home Screen When No Documents Are Open' every time InDesign is starting (even if the checkbox is grayed out).

Actually it's likely you have to run the script just once. And then you can delete it from the 'Startup' folder.

5
  • 1
    Thank you!!!! sounds promising - I can't wait to try it. I'll post results. Commented Feb 1 at 3:42
  • 1
    Unfortunately, it didn't take. In my ID preferences panel the 'show home screen' option is not grayed out - it is entirely absent from the panel. I've learned to live with it. Thank you for having considered my problem. I appreciate your time. Commented Feb 5 at 1:00
  • Alas. Looks like in 2024 Adobe InDesign team want make us love them the hard way. ) Commented Feb 5 at 11:19
  • Script worked Great, is there an undo script?
    – Duke 77
    Commented Feb 10 at 2:17
  • @Duke77 Try to change the second to false to to true. Commented Feb 10 at 10:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.