1

I have been using AI for 25 years, and this problem only recently presented itself: when numerically scaling an object that has a stroke, the object ends up distorted.

I’ve found that the object’s size is measured to the outside edge of the stroke, not the center of it, which is perhaps causing the problem, but I cannot find a preference or anything else that might change the setting so this doesn’t happen.

To solve the problem, I need to figure out how to set AI to measure an object to the center line of its stroke, not its outer edge. This is how it used to be, but perhaps one of the latest updates changed it (I’m currently on v27.5).

Any tips appreciated, thanks.

Addendum

I hope these screen-shots will help better explain my problem. I am accustomed to using numerical scaling to reliably keep grouped technical drawings and graphic assets consistently scaled and undistorted. This issue is significantly hindering my work efficiency!

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

5
  • 25 years is a lot, please don't take this comment as condecention. I trust you are aware of this, but I can't be certain unless I ask..... Does Scale Strokes & Effects option on the Transform Panel change things?? What about Use Preview Bounds in the Preferences? Is that checked? The question reads as though the strokes are merely scaling, and you don't want them to scale. If that's not the case, I'm afraid a couple rudimentary examples may help others understand.
    – Scott
    Jun 23, 2023 at 20:35
  • No condescension felt. I have always kept “Scale Strokes & Effects” on, as it is now. I also always have “Use Preview Bounds” on, and use it to scale imprecisely, but if I want something to scale to an exact measurement, I link the H & W fields and enter either the height or width I need, and allow the other dimension to automatically maintain previous HxW ratio. Lately when I do this, the HxW ratio becomes distorted. This is what I need to solve, via getting AI to measure object at vector line, rather than outer stroke edge. I will work on getting some images up to better illustrate.
    – wabisabied
    Jun 23, 2023 at 21:41
  • Ahhh... Align to Pixel Grid perhaps? That would account for objects suddenly breaking their proportions.
    – Scott
    Jun 23, 2023 at 22:02
  • “Snap to Pixel” is not on, nor are any others.
    – wabisabied
    Jun 23, 2023 at 23:09
  • Sorry, I really hate to post this, knowing the headache it may cause.. but.... I think this may be one for Adobe. From what you've posted, I would strongly suspect a bug in the version you are using.
    – Scott
    Jun 23, 2023 at 23:38

1 Answer 1

1

I see the discrepancy you are experiencing coming from a combination of a couple things.

From Preferences> General> Use Preview Bounds, if checked on, your bounding box aligns with the outer most stroke edges.

If you uncheck Use Preview Bounds then the Bounding Box aligns with your anchor points and not the Stroke.

Having "Use Preview Bounds" checked on, along with your rounded corner Stroke setting (and the geometry of the star shape itself) is giving you inconsistent dimension readings when you are Scaling.

Your Scaling is most likely working correctly but you are seeing it as an error because the dimensions are measuring the outer Stroke extents which are rounded and angled.

EDIT____________________

I am adding this to try and show the unproportional distortion involved with star shape with rounded corner stroke and "Use Preview Bounds" enabled.

enter image description here

4
  • This was my thought as well, but Wisabled indicated that was already looked into and could not be the issue. (at least that's how I read his/her comments.)
    – Scott
    Jun 24, 2023 at 15:11
  • I still think you were right on originally @Scott. I reproduced the OP's example precisely if I had "Use Preview Bounds" checked to on. If I begin again with "Use Preview Bounds" unchecked then things scale exactly correctly with or without stroke with rounded caps. It is the added rounded and angled Stroke width (which is uneven due to star's geometry) that is causing the non-proportional scaling issue when using Preview Bounds for the dimensioning..
    – Kyle
    Jun 24, 2023 at 16:33
  • Coolio :) I can't test in v27. Thanks for explaining! +1
    – Scott
    Jun 24, 2023 at 16:39
  • “Use Preview Bounds” was the culprit. Thank you for the simple fix! Also @Scott thank you for the comment to my question re: this. I mis-interpreted your comment to mean that it should be on, which it was. Turning it off is the solution.
    – wabisabied
    Jun 25, 2023 at 15:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.