16

I used Inkscape to add the text Prostanthera ovalifolia to a PDF generated by R and it came out jagged with bits missing:

The font is jagged and bits missing

The SVG file can be found online here.

Inkscape was re-installed a few days ago on a Windows 10 machine. I have occasionally been editing similar PDFs created by R for several years and not met this problem.

How do I solve this?

7
  • Hi. Welcome to GDSE. It's hard to say without examining the PDF file. What I suspect is that the text is just outlines generated by R, and not an actual editable text object, and somehow the outlines have become messed up, possibly due to insufficient/loss of precision either during the PDF import process, or when outputting the graphic from R.
    – Billy Kerr
    Jun 28, 2023 at 23:41
  • A simple fix would be to delete and retype the text natively in Inksape. Whether this is practical or not depends on how much text there is.
    – Billy Kerr
    Jun 28, 2023 at 23:43
  • Thanks for your reply. The text "Prostanthera ovalifolia" has been added in Inkscape, it did not come from R.
    – Ruth P
    Jun 28, 2023 at 23:44
  • then I'm at a loss. Can you share the SVG? Upload it to svgshare.com and post the link here. You don't need to sign up for an account.
    – Billy Kerr
    Jun 28, 2023 at 23:44
  • 1
    I've found it, it's here svgshare.com/i/umg.svg
    – Billy Kerr
    Jun 28, 2023 at 23:52

1 Answer 1

19

After examining the SVG, I notice that you have a custom dash stroke set on the text.

Select the text object, go into the Fill and Stroke panel (Shift+Ctrl+F), then into the Stroke Style tab

Set the dashes to a normal solid stroke

enter image description hereClick to see larger

Note: If you don't want a stroke, just remove it in the Stroke Paint tab. Hit the X to remove the stroke.

As to how this happened you may have just accidentally hit it, or the text tool has inherited the dashed stroke you used on another object.

If the latter is the case, then to prevent this from happening in future go into Edit > Preferences > Tools > Text, and set the option that says "This tools own style". If you have it set to "Last used style" it will inherit the last style you used, i.e. a dashed stroke.

enter image description here

3
  • 2
    Thanks for all that @billykerr. You're wonderful. The stroke was inherited from the dashed lines I had added.
    – Ruth P
    Jun 29, 2023 at 0:23
  • 1
    @RuthP - yeah I thought so. Did you see my last edit? I added more info on how to stop that from happening.
    – Billy Kerr
    Jun 29, 2023 at 0:25
  • 2
    Yes I did that thanks! @billykerr
    – Ruth P
    Jun 29, 2023 at 0:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.