0

I’m trying to use the Reflect Tool to create symmetry.

By the look of it, it seems as if the path on the left has an outside stroke alignment and the path on the left has an inside stroke alignment.

appearances of the paths

However, when I open the stroke settings panel both are displayed to be aligned to the centre.

On top of that the “Align Stroke to Inside” and “Align Stroke to Outside” options are greyed out for both paths.

panel settings

Anyone know what could be causing this? Thanks in advance.

EDIT:

I think it has to do with the width profile, so I tried to flip the width profile. However the vertical one doesn’t give me the result I want and the horizontal one is greyed out.

cannot flip width profile horizontally

1 Answer 1

1

This is not an Inside/ Outside Stroke Alignment issue. The reason your Inside/ Outside alignment options are greyed out is because you are working with an open path. Illustrator only gives these stroke alignment options for a closed path- which makes sense because Illustrator does not know what is inside or outside of an open path.

I can confirm that if you have a path with a width profile which is non-uniform (weighted to one side of the stroke) then using the Reflect tool will result in a Stroke that is "Flipped Across" the Stroke as you are experiencing.

enter image description here

The solution to this is to hit the "Flip Across" button in the Stroke Panel- with only that particular Path selected.

enter image description here

enter image description here

This seems like a bug to me but maybe for Adobe this is working as expected- you would have to check with Adobe on that.

Side Note- Interestingly, when using the Mirror Me plug in from Astute Graphics the non uniform stroke profile does reflect properly- this is what makes me think this is perhaps an Adobe bug.

1
  • +1 There's been a couple long-standing bugs with stroke profiles (since CCv1 I think). Mostly with blends, but it seem logical that this also may be an Adobe failure.
    – Scott
    Commented Oct 30, 2023 at 17:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.