1

Inkscape opacity problem

I have two rectangles and a line in my Inkscape document. However, all of them do not have solid colors. The rectangles are significantly more red where they overlap and lines and strokes are semi-transparent. How do I fix this? My fill and stroke colors are red and black. The problem occurs no matter which document I am on. I've tried checking if the opacity is not 100, but it is. The display mode is also normal. The version is Inkscape 1.2.2 and I used the RGB scale for fill and stroke. Here is my Inkscape file if you need it: https://www.dropbox.com/scl/fi/vua1ui5vgnc0u71garnc8/opacity-problem.svg.zip?rlkey=c9nch45tsftngdp8fap8tuspi&dl=0

1 Answer 1

0

The object opacity is set to 75%. Change it to 100%. Note that the stroke and fill attributes can also have alpha transparency, which is separate from opacity (which affects the object as a whole).

enter image description here

Sometimes it's hard to see the Opacity slider if your fill and stroke panel is not tall enough. You may need to scroll down to see it, or adjust the size of the panel.

If you use Inkscape 1.3, you can also see that an object has opacity if you open up the Layers & Objects panel. The icon highlighted in red shows the object has opacity applied. Note that layers and groups can also have opacity. You can also change the opacity by clicking this icon and and you can choose from various options to control the opacity/blend options.

enter image description here

You can also see and change the object opacity in the status bar along the bottom left of the main interface window.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.