3

Often when I apply some effects to layers, and I merge them, the ones with effects have their blending mode messed up. They act as if all of their layer blending mode became normal and then merged. But I think sometimes it doesn't happen.

What can I do to prevent this?

  • this has happend a few times for me, i dont know the exact answer but i think it's something to do with having the underlying layer being a solid layer as in having just normal blending modes, easiest way to avoid this is make a copy of all your layers and and then merge - keeping the old hidden but as a backup – MephistonX Mar 8 '13 at 9:05
  • 2
    I find that isolating the layers to be merged, then select all and Copy merged works better than merging or flattening layers when they have layer styles applied - might help, I'm sure there's probably a better way though. – user56reinstatemonica8 Mar 8 '13 at 15:37
  • i found it the order you merge in matters...down to up, up to down. – Muhammad Umer May 11 '14 at 3:26
1

It is an overwriting procedure. This is normal. Before merging the problematic layers you need to rasterize them. Righ click on the layer -> Rasterize.

1

Select both layers from layers panel with Shift and then hit Ctrl + E to merge them. Your effects will not change.

1

Create a new blank layer on top of all other layers. Then select all your layers and then "Merge Down" or CMD+E

Edit* "Merge Layers" also works. Important thing is there is a new blank layer on top, and multiple layers selected below.

1

The Hard Light blend mode on your glow is isolated to the "outer glow" layer FX. Once you flatten the layer and bake the glow style in, you lose the local blend mode of that glow in favor of the layer's blend mode - which defaults to 'Normal'

  • If you want that glow to real-time blend with the layers below it, you will need to leave it as an FX layer.

  • If you are satisfied with what you are placing the glow over, then you can merge your image.

Either way, if you need your glow to be set to Hard Light, then you need some content below it to 'blend' with.

Another option that might be better for you would be to:

  • duplicate your layer & FX
  • sample the colors you like from it
  • set your glow to 'normal' and use that 'blended' color you sampled to approximate what you need.

You can get interesting results by combining a 'drop shadow' with no offset and an 'outer glow'. Set them both to 'Normal' and stagger their sizes to get a gradient effect.

1

I went through a lot frustration because Blend If layers were not showing up after merging. I was using a Blend If layer to make shadows and also had LOTS of adjustment layers, folder groups, clipping mask adjustments etc. The only thing that failed to show up was my Blend If. Here's what I did:

  1. Merge CRL+E only a FEW layers at first, in bottom-most layers and work your way upward towards the top layers.

  2. Obviously, make sure the look of your image doesn't change as you merge. If it does, take a step backward and try to merge a different group first, typically from the bottom upwards. Delete any unnecessary layers, masks, effects.

  3. When you feel like you have simplified it enough, try selecting the remaining layers and merging them into one.

It worked for me, although it took some manual work. If you have more than one image that is giving you a similar problem, you may be able to create an Action that merges groups of layers instead of all at once. That action could be applied to multiple images, but I would be careful to double check each image.

0

Very frustrating. None of the above answers seem to work for me. I've got a layer of rasterised black text, with an orange outer glow that has a blend mode with Hard Light that is also translucent, showing the the layer beneath. -Ultimately creating a firey glow that looks great, but when the layer is merged or rasterised (with the effects), it looks awful. Only thing I can suggest is going outside of Photoshop, and using the screen grab tool, then copying and pasting that [flat] image back into the Photoshop project. I'm sure there's another way, but I don't know it.

  • can you give me psd i wanna try some stuff, as i don't know to duplicate this problem...maybe if i did i'd have answer already. – Muhammad Umer Sep 11 '14 at 2:16
0

Before merging, address any problematic layers by right clicking on fx on each of these specific layers... This will open up the layer dialogue box.. Scroll down to 'create layers'. This will take all layer effects and make all layer styles their own individual layer. Start merging specific layer. If a 'problem occurs' you can than easily tweak a specific layer style. This method may take a bit longer than just merging all but I think you will be happy with the results. :)

0

the best thing is press CTL+SHIFT+ALT+E after applying your blend mode new layer will appear with the blend applied as you wish then delete all the other layers

Not the answer you're looking for? Browse other questions tagged or ask your own question.