0

There was another discussion here 7 years ago, with the title "Kerning in FontForge does not seem to have any effect". There was a problem, and a solution.

I have the same symptoms -- kerning looks OK in FontForge lookup dialog, but does nothing when the font is published (I am testing in Windows, as TTF) -- but apparently a different scenario and a different problem.

I use kerning by classes, not by pairs. And (probably therefore) I don't have such a column anywhere, which could be empty, and which was the solution in the discussion 7 years ago.

There are so many options, when generating the font file. I wonder if the problem could be that some necessary option is not selected in the font generation dialog. This is just so BLIND that such a basic feature could not function, and the program does absolutely nothing to indicate why it could be so.

1 Answer 1

0

I eventually found also the "empty field where you must manually write kern", which was mentioned in the discussion 7 years ago. However, I also ran into the problem of "kern table supports at most 10920 kern pairs". I ended up with an acceptable result -- practically everything kerns much better than what would be the unkerned default -- by selecting only the basic latin (first 128 characters) when doing the kerning lookup. Not sure if this actually makes any difference, but somehow this seemed to make a difference, compared to pressing Ctrl-A before doing the kerning lookup. Then follow the usual advice given everywhere. The outcome seems to be that everything kerns quite OK, including other than basic latin characters, and no problem with "at most 10920 kern pairs". Problem solved, without understanding why it got solved. Not very strong, but if it works, don't touch it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.