0

I am trying to use Bitstream Charter font in Inkscape 1.3.2, however text rendered in that font is invisible (and takes no room). Looking at the font menu it appears to be corrupted.

Font menu in Inkscape

However the same font renders OK in Libre Office.

Font menu in Libre Office

Therefore it does not seem to be a font installation issue on the face of it.

This is what the "invisible" font looks like in Inkscape (the word "Hello"):

Hello in Inkscape

I've tried doing a fc-list:

$ fc-list | grep "Bitstream Charter"
/usr/share/fonts/X11/Type1/c0649bt_.pfb: Bitstream Charter:style=Italic
/usr/share/fonts/X11/Type1/c0633bt_.pfb: Bitstream Charter:style=Bold Italic
/usr/share/fonts/X11/Type1/c0648bt_.pfb: Bitstream Charter:style=Regular
/usr/share/fonts/type1/texlive-fonts-recommended/bchb8a.pfb: Bitstream Charter:style=Bold
/usr/share/fonts/X11/Type1/c0632bt_.pfb: Bitstream Charter:style=Bold
/usr/share/fonts/type1/texlive-fonts-recommended/bchbi8a.pfb: Bitstream Charter:style=Bold Italic
/usr/share/fonts/type1/texlive-fonts-recommended/bchri8a.pfb: Bitstream Charter:style=Italic
/usr/share/fonts/type1/texlive-fonts-recommended/bchr8a.pfb: Bitstream Charter:style=Regular

I've also tried doing:

fc-cache -fv

Is there some other place Inkscape might be looking at for the corrupted font? How do I fix it?

Under Preferences, the User Fonts directory is empty. The Custom Fonts Directory is empty.

My operating system is Ubuntu 22.04.

3
  • 2
    Hi. Welcome to GDSE. it's a PostScript Type 1 font. Inkscape doesn't support that format in Linux any more. Something to do with Pango dropping support. The format is more or less obsolete now anyway and is probably best avoided if you are using modern applications. Find an .otf version instead. There's one here
    – Billy Kerr
    Commented Jun 29 at 9:39
  • @BillyKerr That fixed it, thanks! I got rid of all my Type 1 fonts. Can you please post that as an answer and I'll accept it. Commented Jun 29 at 22:32
  • TBH, I'd rather not add this as an answer since tech support questions are generally considered off-topic here. Sorry about that. But I'm glad that I could help anyway.
    – Billy Kerr
    Commented Jun 30 at 16:59

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.