I am trying to align a text layer to the vector mask directly below it - the top two elements displayed in the Layers Panel in the below image.

For some reason, with both layers selected - although the align tools become active - clicking on any of them does not produce any result.

Through a process of elimination I have made certain that the problem is with the shape layer, not the text layer. The shape layer also behaves erratically in that when I select it and attempt to move it, as in the image, the entire canvas area seems to move (as denoted by the grey outline), but the shape layer itself stays put.

The shape layer is not locked, or linked to any other layers. I have tried restarting PS with the same result. Does anyone have any ideas why this is happening?!

enter image description here


I would add that I tested this kind of alignment in another part of the document, with the following two layers selected, and I was unable to perform all alignments without problem.

enter image description here

Unless there is something I am missing, I can only assume this is some kind of bug? For what its worth, these white boxes that I am attempting to align the text to were copied in from another document, but I can't see how anything might have happened when they were brought over.

  • 1
    You can't align masks. Shape layers (Photoshop CS5 or earlier) consist of a layer covering the entire canvas, then a mask. Vector layers (Photoshop CS6 or newer) will allow the alignment you are seeking.
    – Scott
    Mar 20, 2013 at 6:59
  • in first picture are all those layers suppose to be unlinked. There is no link/chain icon next to white boxes.
    – user8795
    Mar 21, 2013 at 2:59
  • Problem solved. I don't know how I missed that!! Sorry for the stupidity, and thank you for pointing that out, Muhammad. Mar 21, 2013 at 3:18

2 Answers 2


Ok i was able to recreate this problem, and the problem is simply that your layers' vector mask are unlinked with their backgrounds.

When i aligned text layer it didn't have any effect, as you said, but when i linked the vector mask layer with its own background/canvas. It started working. I don't think its a bug, but think about it. How Photoshop is to know that whether you want you text aligned in terms of vector mask, or the canvas. Since both are unlinked. It chooses to do nothing.

Look at this video i just made to show what you were saying i guess:


  • I think your explanation about "doing nothing" is not quite correct: As Scott pointed out in his comment, the layer itself is a 100% canvas with a layer mask. If the layer is not linked to the mask, the mask will not move with the layer and when the layer is "moved" the movement has no visible effect because it is by definition 100% of canvas. Subtle difference, but the movement would have been visible if the layer were e.g. a normal raster layer.
    – horatio
    Mar 21, 2013 at 16:20

As an alternative solution, if you need to find the center (horizontal or vertical), within a document or selection try the photoshop extension: http://guideguide.me/

You can also use it to create columns, margins and baseline grid, plus it's free :)

  • Hm, I tried to find the midpoint of a selection, but it didn't seem to lay a guide when I clicked horizontal midpoint and then GG. Any idea how to do this? I couldn't see anything about it in the How To section. Mar 21, 2013 at 3:24
  • I just tested – if it's working correctly you don't need to click the GG button, just make your selection and click the midpoint button and it should create the guide
    – Jon Chubb
    Mar 27, 2013 at 9:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.