When I paste Cmd+V a new layer is created instead of pasting into the layer's mask that I created.

What I'm trying to do is take a black and white layer and make it the mask of a all white layer. This way I have a white cut-out of the shape in the black and white layer.

I'm coming from a background of working with GIMP, which to me is so much more simpler than Photoshop (really, Adobe?), however, GIMP is very slow on OSX so I'm trying to get used to PS.

9 Answers 9


Alt+click on the layermask icon in the layers palette, you can then edit it.

  • 4
    When I do this, it opens the mask as editable, but as soon as I paste, it jumps back to the main editing window and pastes the content as a new layer again. Sep 6, 2014 at 2:43
  • Make sure the mask is highlighted and not the layer itself.
    – John
    Sep 11, 2014 at 6:16
  • @John That is not the problem. Regardless of which is highlighted, pasting creates a new layer.
    – arkon
    May 12, 2015 at 10:32
  • Yeah, same here, regardless it creates a new layer. Haven't found any answer to this. Apr 11, 2022 at 19:24

Cmd+Option+Shift+V will paste your image inside a selected/masked area. I believe this is what you're asking. You can find that under the Edit menu in "Paste Special"

  • 2
    This is the actual answer to the question, the others, while helpful, do not actually address the problem of pasting creating new layers
    – horatio
    Mar 27, 2013 at 13:50

Copy what you want to paste. Click on the Channels palette. Inside the channels palette click on the mask layer, then paste. Only thing that worked for me.

  • Thanks for the contribution and welcome to GraphicDesign! let us know if you have any questions Mar 7, 2015 at 1:14
  • This was the only answer I could get to work in Photoshop CS3. Feb 26, 2018 at 18:47

when you want to copy/paste into a layer mask, be sure to "alt+Click" on the layer mask and then you can paste into it (or go the mask channel and active the last one)


usually when you're working with masked images in Photoshop, it automatically creates a group containing the image and the clipping mask. The clipping mask object or shape (or whatever your're clipping with) is on top (first in the group) and then the image you're clipping is underneath. if you just paste (or press cmd+V) the new image above the old one, it will overlap the old and be clipped in the mask. Does that make ANY sense?


Copy what you want to paste then select the layer you wish to paste as the mask and click add layer mask and it will be pasted automatically.


Select the clipping mask by Alt+Click. This will make the layer editable. Make sure that what you have copied is an image and not a Photoshop layer. Then, paste normally (cntrl+click).


If you are having difficult with clicking...

  • Click/highlight the mask thumbnail in the Layers Panel
  • Open the Channels Panel (Window > Channels)
  • Turn on visibility for the mask channel
  • Paste.

The Option/Alt-click or Option/Alt-Shift-click on the mask thumbnail are merely shortcuts for these steps. If you open the Channels Panel, then use the shortcuts you can actually see what is taking place.


If you're having issues with pasting the layer mask resulting in a new layer, it's because the answer was missing a crucial step (though maybe common sense for others): Select All.

What worked for me was as follows:

  1. Create a new layer mask on the layer you'd like to copy to
  2. Go to the layer you want to copy from and click on your existing layer mask (make sure the layer mask is highlighted, not the layer itself)
  3. CRUCIAL STEP: Ctrl/Cmd + A to Select All
  4. Ctrl/Cmd + C to copy
  5. Alt + Click on the layer mask of the layer you'd like to copy to (again, (make sure the layer mask is highlighted, not the layer itself)
  6. Ctrl/Cmd + V to paste

The layer mask will then be copied onto your desired layer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.