12

Trying to do something which seems so simple and failing badly. I have created a simple Type layer.

I need to add two strokes to the layer. But I would like the stroke to be on the outside of the layer, but the options for the stroke do not let me select that. The options are greyed out, I have the type layer selected in the appearance panel. What am I supposed to do?

22

Certain objects will not allow the stroke alignment options. Type is one of these objects. While creating outlines of type objects may work in some instances. I, myself, prefer to keep type live whenever possible.

In order to move a stroke applied to a type objects, simply do things how they were done prior to the stroke alignment options being added - with an effect.

Apply a new stroke to the type object via the Appearance Panel. Note you can't merely use the stroke which already resides within the Appearance Panel Characters level of the type object. You need to add a new stroke outside the Characters level. Then choose Effect > Path > Offset Path.

Remember that Illustrator centers all strokes. So if you have, for example, a 4pt stroke and you want it aligned to the outside, you need to move it +2pts (half the stroke width). If you want it aligned inside, you would use a negative value (-2pt) to move the stroke inward.

stroke

That being posted, if you simply want stroke outside of the type, just move them below the Characters item in the Appearance Panel and double the stroke width (since half the stroke will be hidden by the type).

strokes

10
  • 3
    This is a clear and simple answer, but finding out that type doesn't allow it was surprisingly difficult to find on Google. Thank you!
    – dgo
    Jan 26 '17 at 18:48
  • Doesn't work. The options described are not present for a type object.
    – TJJ
    Jun 4 at 11:14
  • @TJJ you are simply incorrect.
    – Scott
    Jun 4 at 18:59
  • @Scott I create a type text field. I select it, open Appearance panel, I don't see the options mentioned here. Illustrator CC2018.
    – TJJ
    Jun 5 at 12:52
  • @TJJ AICC2018 is the same as the screenshots above, the panels meely look slightly different. Please read the answer. This all works exactly the same way in CC2018.
    – Scott
    Jun 5 at 18:57
0

You will need ot right click on the text and choose Create Outlines from the drop down:

enter image description here

Now you will be able to choose the alignment for the stroke.

enter image description here

0

As the previous poster mentioned type won't allow for stroke alignment. However, you can always outline type (ctrl+shift+o) and then align the stroke by clicking the stroke link and selecting one of the three options. Going back and changing the text can be a hassle, as the previous poster mentioned, but for text you're not really changing all that frequently it isn't too bad.

Unfortunate and weird omission by Adobe, but you get used to these things.

1
  • Speak for yourself. I've just discovered this is STILL a problem in AI, and immediately bought Affinity Designer for a friend to save spending time explaining the foibles of AI to him.
    – Confused
    Dec 13 '18 at 22:18
0

The accepted answer is not the best one.

You can outline text more simply just by dragging the Fill style above the Stroke style in the Appearance panel:

Appearance panel with fill above stroke

The Stroke should be set to double the weight you're looking for as the Stroke is still aligned to the centre. However because the Fill style is now above it, the text will render over this and it will effectively be an Outside Stroke.

3
  • While true for objects, Live Type is another matter. You can not alter the stacking order of the stroke/fill on live type.
    – Scott
    Aug 6 '20 at 11:05
  • I have literally just done it, but maybe this is a feature only in the latest releases? – I notice now that the question is about CS6 specifically (which I don't have so can't check). Aug 7 '20 at 12:07
  • I'm trying to do this with version 24.2 (latest) and it is not possible with live type. I can drag 'Fill' above 'Stroke' under 'Characters', but when I release, the order is not changed, and 'Stroke' is still on top. Sep 18 '20 at 3:54
-2

Simply create the style you want with borders and positions on any object, or on a letter outlined for example Object has no importance but used generating style. Then open Windows "Graphic style" and slide your new style on the style table Then apply this style on any text = it's working S

0

Not the answer you're looking for? Browse other questions tagged or ask your own question.