I found myself many times in this situation and I finally decided to ask in a forum. Here's the deal. Let's say I have a red square shape and I make a new layer above it in which I apply a cloud filter and then a noise filter. The problem is that my new noise layer is taking the whole page and I want to apply it only on the red square shape. That's when I right click on the noise layer and select create clipping mask. Finally my noise is applied to my red square only. Now, let's say I want to apply some fx to my red square. Double click on it and in the layer style I apply a color overlay. There it is! How come my noise layer doesn't show up anymore? Looks like the layer style is making the noise layer obsolete.

So here is my question, how can I get the noise layer to always show up even if I apply a layer style to my red square?

Thank you all for your help.

2 Answers 2


The only reason your clipped layer would get hidden is if you apply an Overlay style to the base layer. Overlay styles are designed to cover the internal pixels unless you either change the blend mode or reduce opacity.

So in this example....

clipped and styles

The Gradient Overlay style is set to Multiply, thus letting the white pixels of the clipped noise layer (which is set to Screen) show through.

The Pattern Overlay style is set to Color Dodge, also letting the clipped noise show through.

However, if either of those layer styles are set to Normal, the noise would no longer be visible.

For example, with the Gradient Overlay set to Normal:

Grad Overlay on normal

See THIS QUESTION, which may also be helpful.

  • Thanks Scott for this answer nicely illustrated. After few trials I finally figure it out. What I need to mention for those with the same issue is that the base layer must already has its own color while its layer effect should be a solid white color overlay or a black to white gradient overlay set on multiply mode if the white pixels has the ones to be shown. If you want the black pixels of the noise to show up and not the white, then it should be a solid black color overlay set on multiply mode as well. Thanks Scott for your great answer that helped me to figure it out! :) Mar 30, 2013 at 8:46

Under "blending options" of your effects window, in this case of the red square layer, uncheck "Blend clipped layers as grouped."

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.