2

I'm modifying an existing animated GIF using GIMP. For some reason, GIMP opens it as an RGB file.

But after doing a color analysis it told me there are only 255 colours. That's just right!

However, when I do turn on indexed mode, it generates a new palette which degrades the image.

Even with all the blending/dithering options turned on or off, it applies a new 255 colour palette that is different from the 255 colours that are actually there.

So, how can I fix this?

  • The question is why your Gimp opens the GIF as RGB - it opens and keeps them indexed here on Gimp 2.8.2. – Takkat Jun 17 '13 at 11:52
  • The only setting I found to possibly convert an indexed file to RGB is in Color Management preferences - File Open behaviour. However whatever I tell it to do there it alway opens my GIFs indexed. Do you use CM profiles? – Takkat Jun 17 '13 at 18:25
2

To keep the GIMP imported palette in order, uncheck the "[X] Remove unused colors from colormap" checkbox when you're converting the image mode to indexed.

It only took me 4 years to figure this out :D

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.