10

When I apply a color with the exact same RGB as the fill for 1 shape and the stroke of another, the shape with the stroke shows a slightly lighter color. Why does this happen and what can I do to correct it?

screenshot of the problem
Click image for full resolution

  • Is this in the same document? are there any other Appearance attributes applied? Effects? – Scott Aug 27 '13 at 10:34
  • No effects. Opacity at normal for both shapes – RunLoop Aug 27 '13 at 11:15
  • 1
    There's no common reason why this should happen... people might be able to help if you post a screenshot of the appearance window with each shape selected. – user56reinstatemonica8 Aug 27 '13 at 11:27
  • What happens if both shapes are on the artboard? Do they match then? – Scott Aug 27 '13 at 12:28
  • 1
    Those two circles appear to be the same color. I cliped just the red part of the circle on the right - blew it up a bit and overlayed it on the circle on the left... I think the blue outline is creating an optical illusion. – Don Nickel Aug 27 '13 at 13:13
12

There's a good chance that the effect is caused by your custom stroke. If the stroke shape isn't completely black (because, for example, it was made using CMYK black insted of RGB black), it will show as a slightly lighter variant of your chosen stroke colour.

To solve your problem: expand the shape (Object > Expand; or Object > Expand Appearance...) and give it the correct colour as a fill colour.

  • 1
    I'd bet the brush artwork isn't correct (or not 100%k). Adjusting the brush artwork would fix it rather than expanding. – Scott Aug 13 '14 at 18:49
4

A more desirable approach than expanding the shape is to edit the brush colorization method. If you change it from just "tints" to "tints and shades" it will ignore the shade of CMYK black used in the original brush. Be sure to click "apply to strokes" when it asks you as you exit the window in order to make the change retroactive.

Change colorization method here.

Be sure to click "apply to strokes."

2

Select the stroked object with your Selection Tool.

Select Object from the top menu and then select Expand Appearance

Select Pathfinder then Select Unite.

  • This was the only thing that worked for me, I'll get rid of that -1 for you. – Brandito Sep 12 '18 at 6:49
1

I had the same problem. I think I've found two possible solutions. Since nothing I did would change the color to make it 100% black, I tried these:

  • cmd-c, and 3-4 times cmd-f (This is the lazy solution, but it kind of triple/quadruples the lines.)

  • Drag the brush onto the artboard. Overlap a black rectangle and do a pathfinder (make sure to delete the parts not needed, it might be tedious depending on the brush), apply black 100% and this time around the shape is 100% black. Then all you need to do is drag the brush back into the brush window and make sure the settings are like the original. Then you apply the new brush.

-1

Go to- File-Switch Document Color Mode.

  • 3
    Welcome to GD.SE: Please read tour to learn about our community; then look over How to Ask and How to Answer a question to see what makes a good query, and how best to answer it. We're typically looking for longer answers that provide some explanation and context; we prefer that answerers don't just give a one-line answer; they explain why their answer is right, ideally w/ citations or clear examples. Answers that don't include explanations or details may end up being removed; this should be just as much for future searchers as for this asker; can you revise please? – GerardFalla Sep 9 '19 at 17:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.