When opening a new image from a PNG file in Illustrator as the background for my artboard to trace over I am not able to select any color swatches the only available options are [none] and [registration].

I have black and white available for gradients but thats it. I have checked the color settings and they are set to RGB.

Has anyone come across this before, I'm hoping to either force colors or else find a way to add images from a file into the artboard as when I create a new document the standard colors are all present.

The weird thing is I have just traced round a photo and I cannot remember having this problem in the past!

  • I just found that I could open up a swatch library, select the whole library by clicking and holding the shift key, and then drag and drop swatches into my swatch tab. I don't know if that helps you or not, but it was a quick and easy option for me. – user29506 Sep 6 '14 at 21:28

See this question: Where did my default brushes go?

The same holds true for Swatches, or any library of items.

To recap, when you open raster images, and sometimes PDF files via Illustrator, the files open without any of the stock libraries. This is because the files don't contain the information about the stock libraries, including the swatch library.

To load the default swatches:

  • From the Swatch Panel menu choose Open Swatch Library... > Default Library... > (Then the color space you want - CMYK or RGB)

You can also avoid this by opening a new Illustrator document and using File > Place and then placing a raster image rather than opening the raster image with Illustrator.

  • 1
    On the newest illustrator this opens a new window with the selected swatches, I want to have my colors back on the swatches tool :/ – Dan Aug 15 '18 at 20:20

I'm embarrassed to say I've struggled with this for months. Luckily, is seems I'm not the only one. Unluckily, most people have only given half answers, then reference another half-answer. Here is what has worked for me, using color swatches as an example:

  • Each panel or toolbar dropdown that references color libraries has an icon in the lower left corner that looks like a stack of books. Hovering over it should say "Swatch Libraries menu". Click this icon to open a dropdown menu showing the applicable libraries. Click the library you want opened.

Unfortunately, this opens that swatch library in a new panel, rather than opening the set of swatches into your artwork like any sane person would assume. I'm sure there is a good, logical reason Adobe chose this behavior for their software. It probably makes sense to a graphic artist, but since I'm just a scientist with OCD and a heavy sense of sarcasm, it's lunacy to me.

  • In the new panel, select the colors you want available in your document. If you want them all, click on the first swatch (top left) then Shift-click the last swatch (bottom right).
  • From the new panel, in the top right corner is an icon of three parallel, horizontal lines. This opens yet another dropdown menu with a bunch of sorting options we don't care about, and one thing we do.
  • The top button in the dropdown is "Add to Swatches". Click this button.
  • Enjoy your color swatches, now that they should show up in every toolbar and panel you expected them to be in.

Again, why Adobe chose this roundabout is beyond me. It seems they decided to over complicate a simple task that every user needs to do with every new graphic they create, in order to simplify a task that only master-level graphic artists would use, and one that can be done with a single button.

  • I'm months late to the party but thank you for this. I don't understand why they made it work this way either. Thanks – TeddyTedTed Sep 3 '19 at 9:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.