I've exported tens (if not hundreds) of PDFs with InDesign and I've never experienced this problem. It's pretty weird... The problem is that grey boxes appear around some objects. Next to that, the image quality is very good in Apple Preview, but it's pretty bad in Adobe Acrobat X and Adobe Reader 11.

What happens:

  • All objects with an outer glow get a grey box around them (these include external images but also squares created in InDesign)
  • Some images with a transparent background get a grey box around them (not all, seems random). Happens to PNG, AI, PDF.
  • Image quality is very good in Preview, but bad in Adobe Acrobat X (grained edges). This happens to images, not to text (vector I suppose?)

PDF details:

  • All images are embedded
  • All placed items are high quality

I've tried:

  • Exporting in the standard High Quality settings; both problems occur
  • Exporting in press quality; both problems occur
  • Exporting as Acrobat 4 (PDF 1.3). This solves the grey box problem, but the quality problem remains. I've read somewhere that PDF 1.3 flattens? Maybe this can explain the grey boxes? Using this option is not really preferable since I would like to use hyperlinks in the document and PDF 1.3 doesn't support that.

I'm using

  • InDesign CS6 v8.0
  • Mac OSX 10.8.5
  • Apple Preview 6.0.1 (765.6)
  • Adobe Acrobat X (10.1.1)
  • Adobe Reader 11.0.0

The final document is a professional portfolio which will be send via e-mail so I don't necessarily need 300dpi quality, but chances are people will view them on big monitors so I was thinking at least 200dpi.


I've added a screenshot of an object with a transparent background where you can see the grey box around it. This is zoomed in at 300%.

Screenshot of an object with a transparent background where you can clearly see the grey box

  • The grey boxes at least are 'artefacts': these do show up on most (if not all) on-screen pdf viewers, but will never show in a printed product. You can check whether a box is an artifact by zooming in: if the box remains 1px wide regardless of zoom, it's an artifact.
    – Vincent
    Sep 25, 2013 at 14:43
  • Thanks for your comment, but I don't really know what you mean though. The grey box is showing up on my on-screen pdf viewer, so I'm assuming it will at other people's macs using Preview. It's not 1px wide if I zoom in, it's really a grey box around some objects with a transparent background. I can not take the guess that this won't show up at other people's computers since it's my portfolio. I'll try to add a screenshot to my question to show the issue. Sep 25, 2013 at 14:47
  • I see what you mean. These are not the boxes I was referring to, this is probably another problem altogether. Weird, I have no real clue as to what this may be.
    – Vincent
    Sep 25, 2013 at 14:58
  • You mention this affects objects with an outer glow effect: where is this effect coming from? Is it applied in InDesign or in another application then copied or placed into InDesign? Sep 26, 2013 at 12:06
  • Both. There are InDesign objects (simple white squares with an outer glow) and external files which are placed (not copied) into InDesign. In both cases the grey square shows up in Preview as can be seen in the screenshot in my post. I first thought that the problem was with these external files, therefor I've tested with PNG, PDF and AI files, but the problem occurred with every one of them. Sep 26, 2013 at 16:14

5 Answers 5


A possible solution would be to export your document as a hi-res, high-quality *.jpg, place that in a new InDesign file an then export as a *.pdf. This way, everything is flattened and any artifact will not show up anymore. I'm not sure it will help your quality issues, though.


Incorporating some important info from Scott's comment: Most pdf viewers are full of rendering bugs. Apple's Preview and Adobe Acrobat itself are notorious for displaying artefacts like these, especially in *.pdfs that are optimised for print. Using transparency, shadows, glows and/or blending modes in your file makes these problems more likely to show up.

If you want to create a high-fidelity preview, send a *.jpg or a *.jpg placed into a *.pdf. Those will show properly, without you having a lot of explainin' to do to your client.

  • 1
    I could do that, but it feels like a pretty hacky workaround. I'm sure that I'm missing something here and I'd like to find out what so I'm able to solve it if it occurs again. Sep 25, 2013 at 14:53
  • 1
    @joostvanhoof Apples Preview is full of rendering bugs. You have to dummy-down files for Preview to display them properly. THis is by far the best solution if you are worried about Preview rendering. At least until Apple begins to care about things like spot colors and transparency within PDF rendering. It is a hack... but there's no other way to work around the Apple bugs.
    – Scott
    Sep 25, 2013 at 15:42
  • OK thanks, then I understand where the problem comes from. So I should export the document as high res .jpg in InDesign? Although it's a workaround, it's important that my document is viewable in both Preview and Adobe. Hope this will also solve the quality issue. I'll select the answer as accepted, thanks! Sep 25, 2013 at 22:01
  • Exporting from InDesign to a hires .jpg seems easiest, indeed. Then open a new document of the same size, and place the .jpg.
    – Vincent
    Sep 26, 2013 at 9:04

Solution: Go to Page Display Preferences > Under Page Content > Unselect Show Grid. It worked for me. Good luck!


I know this is an old topic, but I've had the same problem with the gray box showing up on PDFs and printing. I finally got around it by exporting the file as a 2002 PDF. I don't know why the older PDF versions work and not the newer ones, but that's what's been working for me.


As a less than perfect solution to fix this I found that if you create a large box, bigger than the page, and add an effect to it with an opacity of zero and set that box to 0% transparency it would get rid of these weird fray boxes. I think it's a transparency issue, and overlaying that box with the effect, even though it's transparent, will sort of even all the issues out. Not perfect, but it works.


In Indesign, go to Edit>Transparency Flattener Presets, click on "High" as a starting point, then click on "New". In the dialog box that comes up, slide the raster/vector slider all the way to the left. Set the lifework resolution to around 1200/600/300 (whatever your printer's resolution is) and then set the gradient/mesh resolution to 150 or 300 if you are not happy with 150. Save this file as a new Flattener Preset. Then in File>Print, under Output, choose composite CMYK and Check the "Simulate Overprint check box. Under advanced, select your all-new raster flattener.

Works for me every time....

Not the answer you're looking for? Browse other questions tagged or ask your own question.