13

How can I export an Inkscape image as a png without any alpha?

4 Answers 4

11

This has changed a bit.

Now go to Document properties → Page and click on "Background color" (bottom of popup). Adjust "alpha" there. Setting the background color to #ffffffff sets the background to white and opaque. Setting it to #000000ff creates an opaque black background.

1
  • 2
    It seems this will make the background opaque, but still exports an image with an alpha channel. Unfortunately I haven't yet found a setting to remove the image's alpha channel completely Jul 18, 2020 at 2:28
8

In the Faq of Inkscape it says: "change transparency to opaque in Document Preferences and export the PNG file again."

That should fix your problem.

1
  • 1
    Note that this answer is out of date. See Mark's answer for the update. Oct 10, 2017 at 22:33
1

Gabriels comment seems to be correct. Inkscape always exports an alpha channel. My workaround was exporting the image as png, then opening it with GIMP and removing the alpha channel as described here: https://docs.gimp.org/2.10/nl/gimp-layer-alpha-remove.html . Not beautiful, but works.

0

When exporting in "Advanced" area choose "Bit depth" RGB_16. Worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.