I need to image trace some images that are in a custom pattern I made so that I can recolor the pattern. The images were placed there and linked in a previous Illustrator session. When I'm in the pattern editing view and I select the image, ImageTrace itself is not greyed out in the Object menu, but all of the options beneath it are.

How can I get Illustrator to let me turn these images into vectors?

  • Is the image you are trying to trace selected? Is it a raster image? Have you tried embedding the image rather than linking to it? – Scott Oct 16 '13 at 16:03
  • It is selected. I had not tried embedding, but that doesn't seem to work, either. Most of the images are in PNG format, if memory serves. It simply seems that most of the normal image manipulation tools aren't available when in pattern edit mode. – Zelbinian Oct 16 '13 at 16:13
  • Wait.......... you're trying to trace from within pattern editing? That's never going to work. Trace the image then make a pattern. – Scott Oct 16 '13 at 16:19
  • Well, I placed the image into the pattern directly and it doesn't exist anywhere else in the document. I'm not sure what to do from here. Copy-paste-trace-replace? – Zelbinian Oct 16 '13 at 20:52
  • You may need to convert the image to CMYK in photoshop first, this worked for me :) – user44138 May 21 '15 at 11:43

I find I get myself into this situation when I've cut'n'pasted a bitmap image directly into Illustrator and then the Object / Image Trace image has all greyed out options and the Window / Image Trace has no buttons available.

The solution I've found is to Object / Rasterize... it first, as the moment the item is pasted into Illustrator it is an "object" that can be [somewhat] manipulated still (kind of like smart objects in Photoshop). When the item is Rasterized within Illustrator it then sees it as a bitmap image that can be traced.

Once done, and the object is selected using the black arrow Selection Tool (V), the tracing menus come alive.


Image tracing doesn't work on Embedded images. You can unembed images by using this command.

Window > Links > Select the Image and from flyout menu > Unembed Image.

It will ask you to save the image. Give it the desired directory. Image tracing will be enabled.

  • Is this version specific? I can trace embedded images no problem – Cai May 4 '16 at 8:23

Use the Window menu and select Image trace. Make an amendment in this window and this becomes you custom image trace.

Once you have done the image trace you need to expand and this will make a vector.


Be sure that you have enough RAM on the machine that you are using.

There should be a shortcut drop-down at the top of illustrator once a raster is selected. Click the drop arrow next to Image Trace and select the different options. YOu will have to press CMD+Z or CTRL+Z to undo the vector image to try the next quick option.

To get more detailed: Go to Window drop-down and find Image Trace. This will open the Image Trace dialog box. Click the advanced tab to see more control options. Use the drop-down to select whether you want your vector to include color, be grey-scale or black and white.


Release all clipping masks from the image (Object>Clipping Mask>Release). Then you should have the Live Trace option available.


One of the issues I found was that after selecting all my modifiers in the image trace box, unclicking 'preview', then hitting trace. Sometimes you also need to scroll over to OBJECT > IMAGE TRACE > EXPAND to do what you're trying to do.


If the image trace options are in the drop down, and it is just the custom that is missing/greyed out, try the "Image Trace" window under the Window menu.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.