Is there any analogue of CSS rule white-space: nowrap in Adobe Indesign? enter image description here

I know that happens because in Indesign the text can be placed in any arbitrary shape, not only rectangular as it goes in HTML. Typesetting engine is looking for a string that have enough width to fit a word. And if this shape can't fit big word then such a word will be shifted to next text frame, even if a frame does not exist.

The question is how to disable such behavior?

  • this feels extremely non-InDesign. I wouldn't be surprised if it were impossible.
    – Vincent
    Commented Oct 23, 2013 at 9:23
  • Perhaps this is a stupid question, but there is no answer on the internet why this happening.
    – yakunins
    Commented Oct 25, 2013 at 10:02

3 Answers 3


You should make the text box the proper width for the text. If you must have the one line a different width as the rest, make a new text box the proper width and then insert the new box into the flow of text.

(see: http://helpx.adobe.com/indesign/using/threading-text.html )

If you are dealing with a smaller number of single lines of text, break them out into their own boxes and adjust them manually.

If you simply must have one line wider than the rest and insist on not flowing the text through individual boxes, make an image box and set up runaround.

( see: http://helpx.adobe.com/indesign/using/text-wrap.html )


..... not something I'd recommend doing.......

Highlight the text and in the Character Panel Menu choose No Break.

Anther option is to create a table from the text you do not want to wrap. Tables can extend past text frame boundaries. It can be a table with a single cell. Ir simply an inline additional text frame.

  • 1
    his/her next question: "why did my line of text disappear?"
    – horatio
    Commented Oct 23, 2013 at 14:43
  • Sure, I know that this method makes the whole line to be hidden and little red plus appears. The same with the table.
    – yakunins
    Commented Oct 25, 2013 at 10:00

If I understand your question correctly, you want to solve the problem of text overflow when you don't want it. There are different ways to accomplish this, depending on your exact situation.

One is to create the text frame large enough to include your longest line, then apply text wrap properties to the objects on the page that you want to avoid.

Another is to have the text frame resize automatically when you run out of room. You have choices in InDesign that were introduced in CS6 in an extra tab added to the "Text Frame Options" dialog (Ctl/Cmd-B or Object > Text Frame Options...).

Auto-Size Dialog

There's a good demonstration of it in this video tutorial on the Adobe website, starting at 5m 20s into the presentation, but you'll get the hang of it quite rapidly if you just play with the various options.

All that said, if you type a word that is too long to fit in the width available (which can happen if there is an overlapping text wrap area), it will disappear if InDesign can't hyphenate it, either because you have turned off hyphenation, the word has a No Break attribute, or it has a [No Language] setting in the Character panel or Character Style.

  • No, I want text string to exceed text box area.
    – yakunins
    Commented Feb 13, 2014 at 10:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.