I'm at a new job so I'm not sure if this is a Firefox issue or hyperlink issue. Haven't experienced it before.

I created a few hyperlinks (three spots for our company website, two for company email) as part of a catalog created in InDesign. Did PDF export and ticked to include hyperlinks.

If Mozilla Firefox is running then all of the links work. Website opens in new tabs, email opens in Thunderbird (what we're using here). However, if I close Firefox then it freezes up and crashes Acrobat.

Anyone know what might be causing this?

  • Have you tried modifying the links in Acrobat to see what would happen?
    – user9447
    Nov 1, 2013 at 15:08
  • Have you tried having a different browser open and seeing if the links open there? Nov 1, 2013 at 15:18
  • Is Acrobat updated? What version are you running? I remember a problem like this back a few updates ago.
    – ckpepper02
    Nov 1, 2013 at 15:35
  • Brand new Acrobat off Creative Cloud installed two days ago.
    – Ryan
    Nov 1, 2013 at 17:22

2 Answers 2


Two things come to mind. Acrobat has a number of hooks into the OS, and even after a fresh install (and especially after an update) it's almost always necessary to restart the system before everything works normally. OS X and Windows are both subject to this. The other is that Foxit may also have its own hooks into the OS that argue with Acrobat, although I've never used it so that's really just speculation on my part.

  • Don't like the idea of marking myself the answer so gave it to you.
    – Ryan
    Nov 15, 2013 at 20:26

They also use Foxit PDF - actually my computer is now the only one with Acrobat. I opened it in Foxit and got an error message on the links about Trusted Privileges. Looked up what that meant and changed the preference in Foxit.

It then worked in Foxit.

Opened it up and start playing with the comparable setting in Adobe Acrobat only to find that the links now work - without actually making any changes. No idea why changing the setting in Foxit made a difference in Acrobat unless I missed something else that I did.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.