5

I work with Sketchup quite often to make 3D graphics for use in AfterEffects, Photoshop, etc. and with the most recent update (sketcup 2013), I have noticed an extremely annoying bug/feature that in some cases has prevented me from doing work.

When I zoom in on my model, at a certain enlargement, parts of the model appear to be cut-away. Below is an example of this occurring in a model;

enter image description here

The darker grey area is the exterior of the model, and the light blue bits and the white bits are the inside of the model. In this automatic cut-away view, any viewable surface (inside or out) can be selected. This gets extremely annoying when I'm trying to do work that requires extreme detail, which is quite often.

Is there any way to disable this feature, or if its a bug, is there any workaround for it?

EDIT:

Photo of the rest of the model, as per request. It's still W.I.P.

enter image description here

3
  • 1
    This might be better asked over on the software's help site. Commented Dec 30, 2013 at 6:07
  • I do a bit of SketchUp work. Could you post another screenshot zoomed out a bit so I have a better idea what I'm looking at? My initial reaction is that you're on Parallel Projection and just need to switch to Perspective
    – Ryan
    Commented Dec 30, 2013 at 17:59
  • I'm in perspective, this still happens. I'll post an enlarged image, though, as soon as I can. Commented Dec 31, 2013 at 9:16

2 Answers 2

1

move the origin to the centre of the model. it is an easy shortcut method to reduce the clipping issue. it happens due to many reasons, which are:

One is when the field of view (FOV) is set very wide. You can adjust the FOV between 1 and 120 degrees (the default is 35 degrees in SketchUp and 30 degrees in SketchUp Pro). It's easy to unintentionally change the FOV by pressing the Shift key while you are zooming in or out using the Zoom tool. You can change it back, though, by going to Camera > Field of view and typing your desired field of view in the measurement toolbar.

Another situation that can cause clipping is when the Perspective camera mode is turned off. In that case, click the Zoom Extents button (it looks like a magnifying glass with four red arrows pointing outward). The camera zooms out to display the entire model, and the clipping is eliminated.

Another situation is when the scale of your model is very small or very large. In this case, you can change the scale of your model while you work on it. For more information about how to control the scale in a model, click here.

This can also happen if your model is very far away from the origin point (the point where the red, green, and blue axes intersect). In that case, you can move your model closer to the origin point following these steps: Select all of the geometry in your model by typing Control+A or Command+A, or by clicking and dragging the Select tool across your geometry. Change to the Move tool by going to Tools > Move. Grab a corner point of the selected geometry that is on the ground plane and start to move the selected geometry. Type [0,0,0] (including the square brackets) in the Measurement toolbar (which is in the lower-right corner of the SketchUp window). This causes the selected point to be moved to the origin point.

Most frequently, clipping occurs after a DWG import and is caused by a combination of the above points. If you're moving your geometry to the origin or checking for scale, you'll want to ensure that you can see all the geometry in the model. These three steps will help you do that: Turn on all your layers in the Window > Layers menu. Unhide geometry using the Edit > Unhide all command. View all hidden geometry by clicking on View > Hidden Geometry. After making all your geometry visible, go to Camera > Zoom extents to see the full extents of your model. If you find that you have geometry located long distances from the origin, removing that geometry will help resolve this problem.

1

(For me) This happened in ALL the trial versions of SKP. I couldn't find any way of going around this. But the thing is, once you buy a licence and upgrade, everything was fine.

I do not know if this applies to you though.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.