This is ridiculous: I have a simple looping path. It has a stroke and a fill. I apply "Object > Path > Outline Stroke" and it only applies to half the path.

If I break the loop in two places, it works, but the ends don't join well. If I break it in one place, it still doesn't work. If I delete any number of points, it still screws up.

EDIT: I also just tried outlining it, deleting the bad stroke, and re-outlining the fill - but that doesn't work either - I think there's something wrong with the shape.


Wow. So, I retraced it manually and approximately, and it still didn't work, but not only that, I messed up one of the tangents, and suddenly it works. It's the unique shape that is an exception. This is definitely an AI bug.


Before Stroke

After Stroke

Anyone have any suggestions or ideas?

  • No clue. Trash preferences perhaps. If the same thing happens with a newly drawn path, check the Appearance panel for any unusual settings.
    – Scott
    Commented Jan 6, 2014 at 22:30

1 Answer 1


So, I don't know if the question can be answered since I can say nothing more than that it is simply an AI bug for sure, if you'll observe; nonetheless, the slight compromise will suffice for my needs:

Positive slope doesn't work, yet zero or negative slope does

Weird :-?

As a wild guess, it really looks like it's some kind of issue with the determination logic for the bisection of the angles at the anchors - I did another test, and it did do the whole path, but there was a slight pie-sliver break at one of the anchors

  • Most likely Object > Expand (which does the same thing) won't show the issue. I rarely use "outline stroke".
    – Scott
    Commented Jan 7, 2014 at 0:56
  • Well, no, I'm pretty sure it still did.
    – Codesmith
    Commented Jan 13, 2014 at 0:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.