2

I want RGB colors to be displayed in the shape color panel, but instead the CMYK colors are displayed.

Did not find any way to change it... but obviously there should be one. Or probably the colors are RGB and just the label are converted CMYKs?

Could you clarify the issue?

AI CS6

enter image description here

4

If starting a new document, choose RGB as the color space in the New Document dialog window.

If you started your document in CMYK then converted it to RGB... copy/paste everything to an RGB document.

The color mode you start a document in determines the color build for all libraries - Swatches, Brushes, Symbols, Styles, etc. Simply converting color modes after the fact does not alter these library items.

  • 1
    I've created a New Document with RGB option selected, but the color panel in the question didnot change. – Ilan Jan 28 '14 at 5:14
3
+50

I have found the solution to the color representation:

In the VIEW menu we should click on RGB model :

enter image description here

and voila

enter image description here

1

The Swatches in the Swatch Panel you have open there are CMYK colours.

If you need a Panel with RGB Swatches then click on the menu at the top of the Swatch Panel to load RGB (or other, or your own presaved) Swatches. enter image description here

enter image description here

  • the default are RGB colors, (I mean they RGB option is checked as you proposed), but still dropdowns are SMYK %( – Ilan Feb 4 '14 at 16:35
  • In a sense you are correct. If you look at your Swatches Palette while switching the Document Colour Mode from CMYK to RGB (making your CMYK file into an RGB file) you will see the colours 'change' from a CMYK colour gamut to an RGB (and vice versa). The names stay the same because the swatches were originally created as CMYK swatches - and named after their CMYK values. If you wanted you could double click on each colour in the swatch and rename it. But I would then save this new swatch under a new name, showing that it's RGB. – Yokel Feb 5 '14 at 11:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.