0

When I put text over an image and then save as a jpeg using the File -> Save for Web defaults I always end up seeing noise in the text even though it's 100% opacity..

This a a screen shot of what I see in Photoshop:

photoshop

And this is a screen shot of the jpeg after saving. I think the noise I'm describing is most visible in the "A" and the left diagonal of the "Y".

savdd-jpeg

It's not on an edge/corner so I don't think it's an anti-aliasing issue. Is there anyway to prevent this?

1 Answer 1

1

What you're seeing is JPEG compression. You're setting the quality of your *.jpg at a low value, causing the compression algorithm to create this 'noise' -- JPEG is notoriusly bad at areas of identical or similar colour.

In the 'Save for Web' dialog box, try and set the quality to something around 60~70 and try again. If that isn't enough, try an even higher value.

In case 100 quality doesn't satisfy, you'd better try another file type altogether, like PNG-24 or even GIF.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.