4

I have an AI file that contains several linked files, all sorts of psd and image files.

The problem is I don't have access to any of them, which is okay since I don't need the files to complete my job.

So, Illustrator always shows this message upon opening the file, asking to ignore or replace the files. Trying to replace each file is a no go, since there are too many and the names are dubious.

You all know this warning.

So my question is: Can I clean all the linked file references some way?

The file size is also very big for what it contains, maybe cleaning these nonexistent linked file references will chop the file size as well.

8

Open the Links Panel (Window > Links)

Click the link on the panel

Hit the little "Go To" icon at the bottom of the Links Panel.

go to

This will show you the bounding box of where the image is supposed to be..... if it's not there and not needed, just hit the Delete key.

Then save the file again after you've deleted the references. Using Save As.. will probably be better than simply using Save to ensure all link references are purged from the file.

If the image is not there but IS needed, you'll need to replace it as the warning dialog suggests.

  • If I have 20+ links, how to remove them all at once? Going to each one is no fun – nadya Oct 3 at 14:21
1

Try hitting Ignore and check Apply to All. If that does not work, try to unlink the files from your Ai file. Just click on the object and depending on your version there should be an icon in the toolbar to select which says Break Link. Hope this helps.

1

The red circle with a cross is only to indicate that the link is broken. It is not a clickable button. You will have to locate it in the layers panel manually then delete it.

An alternate method is to link all broken links to a file (when prompted in the beginning) and then delete all.

  • Hi Ujjwal, welcome to GDSE and thanks for your answer. If you have any questions, please see the help center or ping one of us in the Graphic Design Chat once your reputation is sufficient (20). Keep contributing and enjoy the site! – Vincent Sep 30 '15 at 12:03
1

You need to click on Object>Show all Then try again to "go to" link. now you can see and select the empty container in your design and delete it by "Del" button.

  • Hi just a guy, welcome to GDSE and thanks for your answer. If you have any questions, please see the help center or ping one of us in the Graphic Design Chat once your reputation is sufficient (20). Keep contributing and enjoy the site! – Vincent Nov 19 '15 at 15:42
0

These links might be on layers that are locked or turned off. If it doesn't seem to be working, check that all layers are on and unlocked.

-1

there is another way to clear the unwanted or missing that is no longer needed in AI.

  1. Select the missing/unwanted link from the link window then select 'Go To Link'(second button from the left)and it will show you where is the location of the missing link.

  2. Then go to edit and then select 'clear'

then it will clear up the missing/unwanted link from your link window.

  • 1
    You just copied what's in the accepted answer, please only add an answer if it's different from the others. – Luciano Apr 17 '18 at 10:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.