0

For some reason after working with a shape for a little while, the transform the points (corners, edges, whatever) get out of alignment. Notice below in the rectangle in the middle.

no align

  • I'm a bit confused. Does this question apply to the application Sketch or to Adobe Illustrator? Or is there some link between these two programs that I'm missing? – Saaru Lindestøkke Mar 6 '14 at 11:02
1

This is more of a comment and a wild guess, but since I needed to add pictures, here it is.

Did you check if you have "Align to pixel grid" turned on? It might be if you created an RGB document, since it is part of the default options for RGB documents.

To check, select a shape and open the Transform panel (Shift+F8). Check if "Align to pixel grid" is ticked.

enter image description here

If you don't see this option, then you might need to open the extended options. To do this, click on the right top corner of the Transform panel and select "Show Options".

enter image description here

If the option is ticked, then the shape vertices will align to exact pixels when you start working with them.

To turn the option on for just one shape, then just select the shape and tick off the option. You can also select several shapes and tick this option off for all of them at the same time.

To turn this option off for all future objects, then click on the top right corner again to show the options menu and tick off "Align new objects to pixel grid".

enter image description here

| improve this answer | |
0

Try going to Edit > Round to Nearest Pixel Edge. That should align everything neatly with the pixel grid.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.