I have created an illustration of a box out of 3 simple shapes in Adobe Illustrator CC. They are actually 3 clipping masks that clip 3 different embedded raster textures. I then turned the whole group into a symbol. See bellow:

enter image description here

The three large blue rectangles correspond to the boundaries of the original raster textures. Even when they are clipped by the smaller shapes, if I hover on the symbol, all the original boundaries are shown.

Is there a way to:

  1. Hide the boundaries of the objects outside the clipping masks? I am planning on using this object several times in the artwork (that is why it is a symbol) and it becomes very annoying to keep seeing the original boundaries every time I move the mouse over one of the many instances of the symbol.

  2. Make the symbol alignment to be based on its registration (as opposed to be based on the boundaries of the whole art outside the clipping masks)? In this case I have aligned the symbol horizontally centred with the light blue line. Notice that, instead of using its registration (middle cross) it is using the total bounding box of all the textures outside the clipping masks to determine its middle point.

enter image description here

  • Have you tried simply applying a clipping mask to the symbol instances?
    – Scott
    Feb 20, 2014 at 21:59
  • @Scott: that might work with this simple shape, but I have had this problem before several times with complex symbols in which case the repeated mask (for each instance) will add as much load to the file as if I would have just repeated the art (instead of using a symbol). I was wondering if I was missing a setting somewhere that reads "Do not allow symbols to treat clipping masks in way different from the way they are treated through out the rest of the system".
    – cockypup
    Feb 21, 2014 at 15:42

2 Answers 2


Unfortunately, this is an Illustrator default and cannot be modified. I have tried unsuccessfully many times, I can appreciate your frustration.


You can do a bit of a work-around, where you physically trim the excess raster image outside of your clipping mask. This tutorial explains it in full detail:


Essentially you are removing all the invisible, clipped area just like when you apply a layer mask in Photoshop. This is a special technique since the clipped images are rasterized and not vector. Hope this helps!

  • Aha! It does not answer my question fully, because as you suspected I have this problem with both raster and vector elements. But good to know how to trim the image, when the element is vector. I had tried the same steps before but was missing the "preserve alpha" option. +1 for the suggestion.
    – cockypup
    Dec 22, 2014 at 16:19

I'm not certain as though you can alter that parent file without actually croping it as needed. I tried using the Direct Selection Tool to move the bounding boxes to the edges as needed, but unlike other vector programs I have used I couldn't manipulate the parent image, only the child mask.

More on it here: http://helpx.adobe.com/illustrator/using/clipping-masks.html

  • the clipping masks by themselves work fine, the way I expected them to work (art outside the clipping areas is ignored). Even if they are grouped. But as soon as I turn them into a symbol, they start doing what I describe on my question.
    – cockypup
    Feb 21, 2014 at 15:38
  • Yeah... I played with that too and got the same result. If the direct Selection tool doesn't gain access to those bounds, I am not certain this is an option that can be changed at this time.
    – Phlume
    Feb 21, 2014 at 16:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.