7

so I'm pretty new to illustrator so sorry if this is obvious - but, I'm having troubles with the transparency of a flower image.

I placed the image of the flower which has no background from a saved photoshop file (psd) and then image traced in illustrator. But I can't now seem to overlay it on itself without the back ground, and also every time I transform, it re-renders the image.

  • Hi there and welcome to GD - not sure if I entirely understand; some screenshots would be nice. Your psd has transparent background, right? you trace it in Illustrator.. can you export as png just to see? – benteh Feb 20 '14 at 22:53
  • Image trace doesn't see varying transparency. If you've got varying transparency in a raster image, it will always be lost when using Image Trace. However, Image Trace should work with solid fill and solid transparent areas. An image sample would greatly help answer your question. – Scott Feb 21 '14 at 0:57
10

What is happening is when you trace your image, Illustrator is making your "transparent background" into "white space". What you need to do is remove this from your trace.

1.Menu > Window > Image Trace

2.A new window will open. This will give you a lot of trace options you can play with and the one in particular you are looking for is under the advanced drop down.

3.Check Ignore White Space

You will now have your cutout object. If you are on a Mac use Cmd+Shift+G etc. enter image description here

Another way to achieve this would be to expand your object and delete it manually. To do this you need to do the following.

1.Menu > Object > Expand - Click ok.

2.Ctl+Shift+G (ungroup) You may need to hit it a few times.

3.You may need to right click on the object and select release clipping mask.

4.Click the white area and delete.

5.Regroup object by selected the whole thing and pressing Ctl+G (Group)

  • The "Ignore white" option did not work as expected under certain conditions... I limited the "Palette" option to output only three colors (all non-white). The result was that the transparency was filled with one of the colors from the palette. The solution: (i) add white [255,255,255] to the custom palette (via the color library) and (ii) save the PNG as a JPEG to convert the transparency to a white background, then perform the trace operation with the "Ignore white" checked as described above. – joelhaus Aug 11 '16 at 23:20
1

An alternative to the answer from Javi, if your source image includes a lot of white, or if it includes a white border, that you don't want to have to rebuild in Illustrator:

  1. Pick a distinctive colour, one that doesn't appear anywhere along the border of your image and is as different as possible from all other colours along the border.
  2. In Photoshop, create a background layer under the image that has the transparency and fill it with this colour.
  3. Export the resulting image as a TIFF file for maximum resolution.
  4. Perform the Image Trace operation (with "Ignore White" unchecked) in Illustrator and Expand the image (select the traced image and click Expand in the toolbar)
  5. Select the individual objects that make up the background that you created and delete them.

Using this method you can retain control over the borders of your image and not worry about losing any white sections.

1

If you "place" and don't "Paste" you should have no background in illustrator if there was no background in photoshop

  • Should.... either way, this doesn't really answer the question. – WELZ Nov 7 '18 at 18:51
  • This is the simplest way. You have to use Bridge though as "Place" isn't an option when opening from your computer (in Windows 8). For tracing, I chose High Fidelity Photo where "Ignore White" wasn't an option. It didn't matter though, the result was perfect. When I tried "Place" wasn't an option so I chose "Open with Illustrator". This too worked, as far as creating the object with no background. However, the expanded object contained extra paths outlining it. If you want a perfect traced image with the fewest steps, select and place from Bridge. – taggart May 27 '19 at 20:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.