I read a tutorial and tried to create a grain effect on a rectangle. I created a rectangle, put a gradient on it and then via the Effects Gallery applied the grain effect, with an Intensity: 74 and Contrast: 50, and Grain mode: Sprinkles.

This resulted in an appearance that DOES NOT resemble the one in the tutorial. The gradient is not grainy, but rather full of pixels, as you can see in the screenshot: enter image description here

I am desperate. How come the effect doesn't look grainy? Is there something wrong with the settings in my Illustrator? I am a webdesign newbie and would be very happy if anyone could help me out.

For your info, this is the tutorial I am referring to: http://vectips.com/tutorials/create-grainy-textures/

  • Can you share the AI file? Or the dimensions of the shape in pixels? I tried it myself an it worked fine. I think BrianC (see his comment) might be on track...
    – cockypup
    Commented Feb 26, 2014 at 20:24
  • @cockypup how do I share a file? well, the size of the rectangle is 250px x 180px. I closed AI and reopened it, but still, it all looks pixelly Commented Feb 26, 2014 at 20:39
  • @cockypup did you create a NEW file?
    – Ilan
    Commented Feb 26, 2014 at 20:45
  • @Ilan: yes, I created a new file. RGB, letter size, at 200% like KentMiller's one looks fine on my laptop.
    – cockypup
    Commented Feb 26, 2014 at 21:15
  • 1
    @KentMiller: Crazy is right! (1) If I open the file you sent me, the grain looks pixelated. (2) If I copy your rectangle from your file to a new file I create, then the grain looks fine. (3) If I create the grain on my file, where it looks fine, and copy it to your file, then it looks pixelated. I noticed, though, you are using CS6. I am using CC. That is the only difference I can find between our files. Did your AI rasterized my rectangle when you opened my file? That usually means that something (font, style...) is not supported. Wild guess, CS6 handles the grain differently than CC.
    – cockypup
    Commented Feb 28, 2014 at 14:58

3 Answers 3


look at the zoom levels, on your document its 100%, on the tutorial its 12.5%. i bet if you make the object you're trying to apply the filter to larger, you'll get the same result.

  • zoom matters in my case. If I zoom in too much I can see the grain as dots, like Kent Miller.
    – cockypup
    Commented Feb 26, 2014 at 20:26

I had the same problem with a tutorial and managed to solve like this:

Go to Effects > Document Raster Effects Settings and change the resolution to High (300ppi).

The grain effect should look fine now.


The foreground and background colors need to be black and white.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.