10

I have inadvertently created an illustration with the align new objects to pixel grid turned on (not sure why it was on, I did not know or ever turn it on) and want to now scale the image. When I turned it off, I scale and it is still affecting the illustration.

So I copy and pasted it into a new document (Making sure that the option was turned of when I created the new document), and it is still affecting the illustration.

How can I scale this object without it being affected by this option?

  • Try adobe's forums for stuff like this, they love solving these kinds of intrinsic problems. – Confused Feb 26 '14 at 21:30
  • @Matt, thanks for using this forum. The answers and format are so much clearer than the adobe forum! – steventaitinger Jan 18 '18 at 16:21
12

To tick off this option for a group of objects

  1. Select all the objects with the selection method of your choice (or more drastically, Ctrl+A to select all the objects in the file)
  2. With them selected, open the Transform Panel (Shift+F8).
  3. Tick off Align to pixel grid

enter image description here

If you don't see this option, then you might need to open the extended options. To do this, click on the right top corner of the Transform panel and select Show Options.

enter image description here

BTW, in the future, you don't have to create a new document. You can just disable the option from the Transform Panel. To turn this option off for all future objects, then click on the top right corner again to show the options menu and tick off Align new objects to pixel grid.

enter image description here

  • I don't know what to make of this. It seems to be a consistent problem. I seem to have this issue always, and never turn this option on. I have made sure I have turned it off in the transform panel and it's still snapping to some point! But it's not snapping to a pixel because the point is something like 20.267x20.657. Really frustrated. Is this a new feature in CC? I didn't run into this issue with CS6. – Matt Bingham Apr 3 '14 at 13:29
6

If you want to disable it in Illustrator CC2017 follow the steps below since it was changed:

First click this Icon in the top right Corner:

Step 1

Then click the following entry in the Menu that popped up:

Step 2

After that, click this Button to disable Pixel Grid Snapping:

Step 3

2

Drove me crazy as well. Don't forget to untick the box for new documents in addition to the solution above. enter image description here

German Screenshot

  • It does not seem that you can turn off the feature for all future files created. You can only turn off the feature for future artwork added. You have to remember to turn off the feature every time. – beaconofknope Mar 2 '16 at 1:23

protected by DᴀʀᴛʜVᴀᴅᴇʀ Oct 10 '16 at 5:23

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.