10

So I've edited a photo in Photoshop and I try to save it as a JPEG, only it doesn’t give me all the options for formats; no PNG or anything. Why is this?

Anyone have any suggestions or know any possible fix for this?

enter image description here

  • Not sure if I understand, but there is the "save as" option, and the "export" option. Those should cover it? – benteh Mar 22 '14 at 1:39
  • 3
    Is your file over 2GB in size? – Scott Mar 22 '14 at 2:18
  • JPG doesn't support layers. you need to uncheck the Layers box. – BrianC Mar 24 '14 at 17:37
16

If you’re using a version of Photoshop earlier than CS6 and your document is 16-bit, or if it is in a color mode such as Lab or multichannel that isn’t supported in JPEG format, then JPEG won’t be offered as an option on save.

  • Image → Mode → RGB Color

  • Image → Mode → 8 Bits/Channel

Then Save As.

One of the much-welcomed features in CS6 (or maybe CS5 – I forget), was that 16-bit images could be saved directly to jpeg, with Photoshop doing the conversion to 8-bit on the fly, but that still means that if your document’s color space isn’t available in JPEG, then Photoshop won’t offer JPEG as an option when saving.

5

You file is probably too large. I had the same problem: the resolution was over 25000×30000. Reduce the file’s dimensions, then you can save in JPEG.

  • I'm still not sure why this limitation exists in Photoshop when I have seen JPG files much larger than those dimensions. – terminex9 Jan 18 '16 at 15:12
1

For me in Photoshop CS6, I had JPEG available, but no PNG. The issue for me is that PNG format does not support the CMYK color mode. The solution was to change to the RGB color mode via:

enter image description here

0

If the document is in CMYK mode, it will not allow you to export as PNG. Convert it to RGB and that should fix it

0

Please change the image bit to 16 or 8, if you are using 32bit, it will never allow you to save as a JPEG or PNG images,

-1

i had the same problem.. nothing worked.. if plugins & version are fine do this- (based on CS3 version) on near right corner of Photoshop screen find a drop down that says 'workspace' - from it select "default work-space"

create a new file and try saving it

-1

enter image description here

Change the resolution when you create new photo. Select pixels as units for height and width.

When you create a new image use this as a default. File → New with: 450 pixels, height: 450 pixels, resolution: 72 pixel/inch, color mode: RGB color 8 bit

  • 1
    I did, I still don't understand how this answers the question or adds anything beyond what Alan Gilbertson's answer has already tackled. – Vincent Feb 20 '15 at 11:45

Not the answer you're looking for? Browse other questions tagged or ask your own question.