0

I'm having issues exporting graphics with some of my lines disappearing. I'm a complete novice to illustrator, so sorry if this is something really basic.

The image should look like this: How it should look

Unfortunately, it is exporting like this: enter image description here

Thanks if you are able to help! Ps. I noticed it does the same thing if I open the flattener preview.

2
  • are you on CS3? or got files from CS3 and opened them in other version?
    – Ilan
    Commented Apr 17, 2014 at 10:02
  • Exporting to WHAT? the export interface is different ore each format.
    – joojaa
    Commented Apr 17, 2014 at 16:22

4 Answers 4

2

When I am exporting a graphic from Illustrator, I tend to be quite cautious and make sure that everything is converted to paths in case anything is lost. It looks like only the 'second' line markers (around the circumference) that are really missing; how did you make these?

If they are all individual rectangles copied rotationally from the center, using the Rotate tool, then you shouldn't be losing any of them. If they are all individual 1px strokes, or if it is a 1px circular path with dots/dashes (constructed under the Stroke menu), then you might have trouble with exporting these.

If not, please let me know how you made the second markers so I can offer better assistance. :)

4
  • Thanks @rpauldesign. When I originally created them, I'm pretty sure they were created as individual 1px strokes (I didn't know any better). I know that I have copied and pasted the lines around between files which may not be helping.
    – user22215
    Commented Apr 17, 2014 at 9:27
  • Ah I see. Strokes and dashed lines can be a bit unreliable when exporting/ pasting into other programs - I would recommend converting the strokes to paths, by using the Expand command (Object > Expand, or Object > Expand Appearance - I can't recall the difference!). Once you're done, you could tidy up the file a little by condensing all of the strokes into one compound object - just select them all and click Ctrl+8, but it's completely optional! Commented Apr 17, 2014 at 9:32
  • I'm afraid using the Expand command didn't solve the issue. I found that running 'Flatten Transparency...' did the trick. (I'm not quite sure why). Thanks again in any case!
    – user22215
    Commented Apr 17, 2014 at 9:55
  • No problem at all. :) Commented Apr 17, 2014 at 9:56
0

Select the object , and the go to Object Menu ---> click "Rasterize"

2
  • that doesn't relate to the problem at all
    – Luciano
    Commented Apr 20, 2017 at 9:32
  • @Luciano this could solve it but depends on how the OP is trying to do the export. If the person wants to export as a PNG for example then rasterizing it, exporting, but not saving over their vectors would be a potential solution.
    – Ryan
    Commented Apr 20, 2017 at 15:01
0

I came up with the same problem and noticed that I had the Overprint turned on for that object .

To turn off Overprint in Illustrator: Select the object in Illustrator then go to Windows -> Attributes to open the Attributes window - make sure that you turn off (uncheck) the Overprint fill and Overprint stroke boxes for that object or group.

You can also change to Overprint preview to see if it's working: View -> Overprint Preview.

0

Increasing the weight of the lines was sufficient for me to resolve this issue.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.