1

There is smooth mode (3 on keyboard if I'm correct) to show objects 'smooth' in the viewport, but when I render it, there is no smoothing.

What should I do in order to get a smooth render?

I've tried to look for tools for smoothing, but was unable to find anything. In 3ds max I could achieve it by applying the modifier Turbosmooth.

6
  • What renderer are you using?
    – mhlester
    Apr 29 '14 at 22:43
  • I'm using mentalray
    – Avdept
    Apr 30 '14 at 6:35
  • If you're using mental ray, it should render smoothed automatically. My answer can't possibly be helpful can it?
    – mhlester
    Apr 30 '14 at 6:36
  • It is helpful, i was about to switch to Vray, so any info is welcome :)
    – Avdept
    Apr 30 '14 at 6:41
  • I've confirmed, Mental Ray doesn't require anything special. If it's smooth mesh in the preview, it'll render that way by default. The only way I could break it was if I unchecked Use Preview Level for Rendering in the shape attributes, and set Render Division Levels to 0. I'm guessing you didn't do that
    – mhlester
    Apr 30 '14 at 15:28
4

I'm going to assume you're using V-Ray. It's the most popular renderer that doesn't by default inherit from the smooth mesh settings.

  1. So, you've made a cube, and pressed 3 to smooth it:

    viewport smoothed

  2. When you render, it isn't smooothed:

    render not smoothed

  3. You have two options.

    • Enable subdivision on the shape (attribute editor for the shape node): shape smoothing
    • Globally tell V-Ray to render based on the viewport subdivision (render settings): global smoothing
  4. Either option will smooth your render:

    enter image description here

4
  • I'll see what I can come up with when I get back to the office in another 9 hours
    – mhlester
    Apr 30 '14 at 6:42
  • Hey in my attribute editor under - attributes- there is no vray option do you know why this is? thanks
    – user27982
    Jul 31 '14 at 3:11
  • @austin V-Ray is a third party renderer (plugin). If you haven't installed it properly you won't have the menu. Are you rendering in V-Ray?
    – mhlester
    Jul 31 '14 at 4:32
  • i dont have v-ray option..:(((
    – user72309
    Jul 28 '16 at 8:24
1

Or you can apply a Modify > Convert > Smooth Mesh Preview to Polygons on your mesh. It will then render properly on all renderers... but you'll lose the ability to further modify your object using smooth mesh.

1
  • Hi Laurent, welcome to GDSE and thanks for your answer. If you have any questions, please see the help center or ping one of us in Graphic Design Chat. Keep contributing and enjoy the site!
    – Vincent
    Apr 8 '15 at 10:21
1

You need to create a subdivision approximation in mental ray and have smooth mesh preview on:

  1. Go to windows rendering editors > mental ray > approximation editor.
  2. There is a subdivision rollout in the approximation editor.
  3. Under the subdivision rollout hit the create button.
  4. Make sure smooth preview mesh is on in the attribute editor.
  5. Render
1
  • Thanks for the contribution and welcome to GraphicDesign! Feb 14 '16 at 21:12

Not the answer you're looking for? Browse other questions tagged or ask your own question.