If you know about Data Merge, you know most people have trouble with styles or with actual entries. Here, I'm having trouble with the layout itself. The document I'm working on will shift down and to the right when created a Multiple-Entries layout, instead of sticking to the upper-left as expected.

Aside from the placement of the new data merged items, everything displays correctly! Styles are good, info is imported correctly, spacing between objects is correct. Just the whole thing is in the wrong place.

Attached below is a screenshot. Anyone seen this problem or know a solution? It's happening on two different computers, both with InDesign CC.

Layout Problems with Data Merge, InDesign CC

  • hmm never had this one occur. Could you screenshot it with the menu up but the Preview unmarked?
    – Ryan
    Commented May 7, 2014 at 17:19
  • It looks to me like the first object (the one that is selected) is perfectly centered in the page, maybe there is a clue in that...
    – Circle B
    Commented May 7, 2014 at 18:56
  • Just as an update, Scott, this is logged as a bug by the InDesign team that covers this feature, and is slated to be fixed. No date yet, though. Commented Jun 6, 2014 at 4:59
  • Does anyone have found a solution for this problem. I am facing it right now. Thx
    – user53305
    Commented Oct 28, 2015 at 15:12

8 Answers 8


It is a reported issue associated with custom page sizes and Preview of multiple record layouts.

This problem can be demonstrated quite easily by changing the page dimensions after creating it, and I'd guess that's what you've done. The multiple record preview snaps the multiple blocks to the designated margin position relative to where the edge of the page originally was when it was first set up (the original page dimensions).

Making the page narrower results in the output being placed off the page to the left. Making it wider offsets things to the right. Making it taller shifts things down, and so on.

The solution is to create a fresh document and set your dimensions, margins and columns in the setup, not after the fact. Copy your text block to the fresh document, connect the data file, and go from there.

Note: According to some information in the Adobe InDesign user forum (which I couldn't reproduce and suspect only applies to CS 5.5 and earlier) don't preview it. Make, as one user put it, "a leap of faith" and just go ahead and create the merged document without preview.

  • for Indesign CC(2014) guess what @Alan! this bug work either in standard pages and when I create the document without review the frame still shifted and the images disappear.
    – hsawires
    Commented Mar 11, 2015 at 8:16
  • Be sure to report the bug through the Adobe website portal, with the details of your system setup. Commented Mar 13, 2015 at 8:47
  • I Don't think it is necessary as they fix this issue yesterday. - please check my answer on top. Thank you @Alan
    – hsawires
    Commented Mar 13, 2015 at 9:57
  • Hey, that's great news! Thanks for the update. Commented Mar 16, 2015 at 22:39

I was running into the same issue with multiple records not loading in. Try and check the following:

  • Have only one instance of the item that is going to be copied remaining on the page.
    • You can do this easily without affecting your existing document.
      • Group your elements.
      • Copy them.
      • Create a new document with the final document size to be printed.
      • Paste in Place (Cmd + Shift + Alt + V).
  • Make sure you are working on the final document size to be printed.
    • i.e. if the final template is a name tag slide with 6 badges on a letter document, your document size should be letter-sized.
  • Place a box with a border and the exact size around your elements.
    • This helps with the layout and determine where overflow may be taking place. If you want, you can place the box on a separate layer that you can toggle on/off.
  • Ensure your margins, column spacing, and row spacing are accurate.
    • Have one manually laid out document on screen as a reference
    • Start with zeroed out values and increment slowly to adjust
  • Avoid stray graphics. Create a separate document for repeating.
    • This goes hand in hand with the boxing advice. InDesign is assuming all the elements are going to be repeated. It draws an invisible container and repeats across with your specifications. Then it proceeds to fill the data in. However, if you have stray graphics, that invisible container is going to be larger than your repeating object, preventing it from rendering correctly.
  • Make sure your spreadsheet is clean
    • Check your spreadsheet before hand for stray characters. This can cause overflow problems (use Auto Text Sizing).
    • InDesign does not process line breaks in Data Merge. If you need line breaks, use a non-standard character to replace all line breaks. Then after merging, use Find and Replace to replace all your non-standard characters with line breaks.

I recorded a quick screencast demonstrating a small problem with Multiple Records and subsequently fixing the issue: https://www.youtube.com/watch?v=7O9sHTpCgMU


I've had this happen multiple times and it is a known issue with the Data Merge in InDesign.

Steps that have helped me:

  1. Clean spreadsheet data.
  2. Make sure margins are wide enough otherwise it won't flow down properly.
  3. Once the single entry is set up on the Master Layout preview the data merge. (it will more than likely look funky that's okay)
  4. Make notes of all of your measurements, margins, columns, rows, everything.
  5. Merge. If it ends up floating lower and to the right, then delete everything and start a new doc, manually inputing all the measurements in a new doc then merge once.

I've found that the more I've fiddled with placement the worse the merge would get. Once I get the measurements just right, a new doc with clean (background InDesign) code would make it work. I also work in a small batch (one page) until it is the correct layout. The more data indesign has to import, it seams, along with the merge script things can go wrong. One large merge after your measurements are in place help lessen the likelihood that InDesign is going to screw up.


Data Merge in Indesign CC has been resolved in their last update today. Just update your version and it will fix the data Merge problem.

Keep the Good Job!


The secret is the preview,.. create a new document and merge your data again but never try to preview the result. Just generate the new document.

for some reason the preview is aligning the first card (or whatever you do) to a wrong edge (or a wrong center point) and this feature is stuck in the document itself, so redo your work and never preview it.

I'm still testing this situation, may be I find a better solution.

  • Hi Ahmad, welcome to GDSE and thanks for your answer. Please don't use ALLCAPS in your posts, it is considered bad form as it reads like yelling. Thanks! If you have any questions, please see the help center or ping one of us in the Graphic Design Chat once your reputation is sufficient (20). Keep contributing and enjoy the site!
    – Vincent
    Commented Nov 10, 2015 at 13:58

I started using InDesign in July 2016 and was still having this problem in the CC 2015 release (I don't work someplace that keeps things updated). What I found fixed the problem was to right click on one of each element's frame "nodes" and lock each element in place. Doesn't seem like something that should have to be done, but it worked.


I don't know why, but this happens to me, too. The way I worked around it was to add margins to offset the objects back to the desired position.

For instance, if my merged information is too far down and to the right, I add to my bottom and right margins, respectively, to push things back in place. You can get it pretty close with guesswork, and then continue to adjust your bottom and right margins until you get the positioning you need.

I know it's a pain in the neck and should not be necessary, but at least it's a workaround until Adobe fixes the bug. A good thing is that it seems to remember these margins in the saved file, so once you get it right, it will continue to produce reliably-positioned output from then on.


This will be the shortest answer, but something I haven't seen mentioned that helped me.

Removing the page number text box from the merge "template" before merging. Then titles and pages can be added to resulting merged document.

After 20 minutes of troubleshooting, this fixed my issue. Hope you find this answer helpful.

P.S.: I'm using CS 5.5 at work and upgrading to a newer version is not an option.

Not the answer you're looking for? Browse other questions tagged or ask your own question.