2

I have a document of 27 pages. I've used the same paragraph styles for all of them. When I export it to a PDF, the text on some of the pages look stroked although I haven't used a stroke. I took a print out and they look the same but when I look at the PDF files the difference is visible. How do I fix this?

  • Have you tried viewing the PDF on different computers on the same operating systems, and then on a different operating system? Assuming you're on Windows 7, try viewing the document on another computer that is running on Windows 7. If it's fine there, fault's on your computer. If not, then try Windows 8. If it's fine there, fault's with W7. If not, try Mac and Android or another OS. If it's fine there, it's a Windows problem. If not, I have no idea what's wrong. :D – Payod Panda May 8 '14 at 15:23
  • Could we have some screenshots, please? :} – thebodzio May 9 '14 at 2:04
1

On the pages where the text appears to be outlined (I think that's what you mean by "stroked"), it sounds as if you have some kind of transparency effect that overlays the text. This could be a Blend Mode applied to an image or colored object, a drop shadow, or something similar.

Because transparency is flattened in many types of PDF output (and most PDF viewers assume that it will be, even if the PDF itself contains live transparency), any kind of transparency that overlays a piece of text (or any vector shape, for that matter) causes the entire region to be rasterized.

You can check for this kind of thing using InDesign's Flattener Preview (Window > Output > Flattener Preview), and you should, because it can be a problem with small text sizes. As an example (and just to make it really obvious), I've drawn a box over some text, made the fill transparent and given the object a drop shadow.

enter image description here

Flattener Preview shows where vector items will be rasterized in order to preserve the appearance of the transparency:

enter image description here

Notice that the area which will be rasterized extends beyond the visible edge of the drop shadow.

It is a best practice in InDesign to place all text on a layer above any areas that have transparency applied. When the transparency effect is under the text, all the font information remains in vector form inside the PDF.

Effects like this can often be more obvious on screen than in print, because the PDF viewer's rendering engine is working with a much lower resolution display than the fine dots of a printer output.

The reason for all this complexity about flattening is that PostScript, the page description language created by Adobe that has been the standard for decades, doesn't know about transparency

0

while exporting to PDF, do include "FONTS" .. and "prepare it for printing".. It will use maximum resolution for images. And fonts which are being used in file will be embeded in PDF file.. otherwise, OS and PDF readers tries to find the maximum next matching font if PDF used font is not available in computers....

Secondly most of the time PDF viewer settings are set FAST or DRAFT privew to faster preview of pdf.. while printing, PDF understands the quality needs Higher resolution and finest font. This setting are also available in PDF export screens.

I hope this could help you in resolving the issue..

Thanks

0

Have you tried zooming in and out? When a document is zoomed in at an odd number (like 87%) you get letters that looks heavier. Simply zooming to a round number usually fixes the problem.

Hope that helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.