1

I'm running Maya 2013 student edition on Mac and 'Input' is missing. I'm following a tutorial in which i can see where it should be.

I've seen a lot of answers to this being "turn on Construction History" but I have tried that, and it doesn't work. Creating objects before and after, restarting Maya each time. Theres also an alternative to delete maya's preferences from the hard drive, but i can't find them.

I'm running Mac OS 10.7.5 Lion and this directory /Users/username/Library/Preferences/Autodesk/maya/en_US/2014/prefs isn't possible. After /Users/username/ there is no Library, that is found before Users.

Going into /Macintosh HD/Library/Preferences/ doesn't show any maya files that i can tell.

Is there a fix to this? or will i have to uninstall and reinstall Maya?

  • What "input" is missing? – mhlester Feb 8 '14 at 5:47
  • We need a bit more information, what Tutorial are you following, what input are you missing? – Shannon Hochkins Feb 8 '14 at 11:39
  • If you right click on an object and select Inputs > All Inputs do you get anything in the dialog? That means you have construction history and aren't seeing it. If not, your history is not getting created – theodox Feb 8 '14 at 17:38
  • @ShannonHochkins I'm following this tutorial youtube.com/watch?v=F-hirvikh7w on hands. The Input is under Channel Box/Layer Editor. When placing an object in, such as a polygon, Input shows up. I'm trying to follow his first steps of placing in an image plane object and lowering it using Input, but it doesn't show up like his. Right clicking the image plane object and selecting Inputs > All Inputs does not show anything in the dialogue box, so it must not be aware of the image plane object. – Vituvius Feb 8 '14 at 19:50
  • are you selecting the camera that the image plane is attache to? – theodox Feb 9 '14 at 2:40
2

Accessing your Image Plane (the "Input"):

The "Input" you're looking for I assume is from 4:44 in your video. They made a change to image plane connections in Maya 2013. From the release notes:

Beginning Maya 2013, the imagePlane node, which was previously a dependency node, is now a shape node.

A few ways way to get to the image plan settings is this:

  1. Viewing through the camera which has the image plane attached, select View > Image Plane > Image Plane Attributes > imagePlane1 (or whatever it's named)
  2. Select the image plane in the viewport.
  3. Select Window > Rendering Editors > Hypershade and select your image plane from the Cameras tab.
  4. Select Window > Outliner and choose the Image Plane there. Looks like it's now on the root rather than under the camera.

Once you have the image plane selected:

  1. Open the Channel Box/Layer Editor if not already open, by pressing the button in the toolbar or right side collapse bar.
  2. Adjust parameters as needed. The one referenced in the video is Center Y.

Finding your Maya Preferences:

  1. Go to your user folder. Easiest way is generally to select it from the sidebar in Finder: enter image description here
  2. You'll notice there is no Library here!

  3. Select Go > Go to Folder (++G)

  4. Type Library and press return. enter image description here

  5. A hidden Library folder appears, in which you can find Preferences > Autodesk > maya > 2014-x64 > prefs to delete, if so desired.

  • Thank you, I feel like an idiot. I was looking for Input so much I didn't try to adjust any settings such as "Image Center Y" underneath the heading of ImagePlaneShape1. Plus, I now know the secret folder search. Awesome, thanks again. – Vituvius Feb 10 '14 at 18:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.