0

When I open the following image in Photoshop (CS5):

enter image description here

This is how it appears, and how it saves:

enter image description here

For some reason, the aliasing is ignored and the edges become completely jagged. Can anyone explain why this would be happening, and how to avoid it?

Update: Seems this is the issue it stems from: Why can't Photoshop properly open this PNG? Fireworks opens and saves it fine.

2 Answers 2

4

The original file looks like a minified PNG file. Unfortunately, Adobe Photoshop cannot save images as indexed PNG files with alpha transparency, and Photoshop CS5 and below cannot even display them properly. The file itself was probably generated with tinypng or similar. You could maybe try their plugin for Photoshop and see if that will let you open that file and save it without loss of quality on the edges.

Edit: if you have access to fireworks, it should also be able to open and render the file correctly.

4
  • 1
    "The original file looks like a minified PNG file." How did you find this out? Just curious. May 19, 2014 at 23:46
  • 3
    @JoshBjelovuk When you open the PNG in photoshop, it displays as an "indexed" file under image > mode. When you are looking at the file in the browser, though, it shows anti-aliased edges. That means it's got alpha transparency. Photoshop supports .PNG alpha transparency on 8-bit RGB images only, not on indexed PNGs.
    – kgcreative
    May 19, 2014 at 23:54
  • So the only option here is to pay 35 bucks for a TinyPNG plugin? Is there some way I can convert from indexed to 8-bit RGB, then open in Photoshop? May 20, 2014 at 0:20
  • 1
    If you have fireworks, it should also open and render the file correctly
    – kgcreative
    May 20, 2014 at 2:31
-4

Just re make the logo in photoshop or illustrator, looks simple enough ?

1
  • 1
    I'm sorry, but imho this does not attempt to answer the question. It's a workaround, and a clunky and legally shady one at that.
    – Vincent
    May 20, 2014 at 12:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.