When working on logo design projects, there are some things in Illustrator that doesn't work perfectly. For example, when I need to make rectangle and then put in rounded rectangle and then aling to centre, it doesn't do that perfect. Why? There are lots of more examples to tell you but I think you get the point what I'm talking about.

  • Is snap to grid on or off?
    – Ilan
    May 24, 2014 at 9:15
  • Snap to point is on with 1px.
    – istoby
    May 24, 2014 at 11:35
  • Just tried to make some objects and to edit those who had problem, but still exist. I needed to put very close two rectangles but program doesn't allow me to do, it goes over other object or way too much space from it.
    – istoby
    May 24, 2014 at 11:43

5 Answers 5


For anyone else searching, I believe the problem is a little option when you first create a new document. It drove me crazy for the longest time. It causes objects not to line up correctly. Unclick align to pixel grid, and you should be good to go.

Pixel grids are useful for designing icons for the web, and web design in general, but when creating logos it can cause problems. A pixel grid is different from a regular grid.

  • One of the most devious checkboxes in Illustrator indeed!
    – Tom
    Aug 4, 2014 at 7:26

Aligning objects, (and especially strokes) in Illustrator can be tricky. There are two options that are relatively hidden / hard to grasp, and that can easily make your life hell if you don't know about them.

1 - When you create a new document:

Click "Advanced", then "Align New Objects to Pixel Grid" to uncheck it.

enter image description here

2 - Transform Panel

In Window > Transform, you also need to make sure, after selecting your object, that "Align New Objects to Pixel Grid" is unchecked (one would think that this option is disabled after you went through Step 1, but nope).

It's also important to notice that you will need to do this for every single object that you want to align precisely (yes, just because one object can be aligned precisely and just because you went through Step 1 doesn't mean that you can align it if the object you want to align it to has that checkbox ticked...).

Also, it's very important that you do not uncheck this box by mistake. If you select precisely aligned objects and uncheck it, your objects will all shift significantly out of alignment.

enter image description here

3 - View Menu

In the View Menu, uncheck "Snap to Pixel" and other "Snap" options.

enter image description here

Voilà! You should be able to create freely...


If I understand you correctly, you have two or more objects, and want them both/all to centre. Some screenshots of your problem might help, but if I got it right, here is what I would do:

In align options, choose horizontal align centre

enter image description here

Then choose vertical align centre

enter image description here

And you will get this:

enter image description here


The "Use preview bounds" option (in the pulldown of the align menu [shift+f7]) can also cause unexpected results.

However, I think the snapping is what is causing your problem. In pixel-preview mode a 1 pt line will be 1 pixel wide. Illustrator will snap your anchor points (not the stroke edge) to the grid. So the stroke will end up half a pixel over the grid.

You can try setting the 'Align Stroke' option in your stroke menu (ctrl-f10) to go to the inside of the object. That way the edge of the stroke will align with the outer edge of your path.


Stroke weight is ignored in alignment, so an object with a 1pt center stroke will appear offset by 0.5pt on its axes, for example. Setting stroke alignment to "inside" will prevent this, and any blurriness when rasterizing strokes of odd-numbered weights.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.