I have an object in Illustrator with a chevron pattern that I created in Illustrator. When I export as a .png file or rasterize image file, it shows horizontal lines.

Anyone have a clue why it does this? I am at a complete loss. It's not the seams of the pattern.

Below is a .png file export of the image:

white lines

  • Hi and welcome to GD - I am sorry, I am a little lost here: the image you posted, that is what you want but not what you get? And I do not understand what you mean by "horizontal lines" - are those on top/in addition to/instead of your chevron pattern? Can we have an image?
    – benteh
    Commented May 24, 2014 at 23:52
  • Have you tried testing this on a different computer to make sure you dont have a GPU issue?
    – user9447
    Commented May 25, 2014 at 14:02

8 Answers 8


Be certain to export with Art Optimized anti-aliasing selected.

Note the hairlines coincide with the dashes on the right. It's a flattening issue which Art Optimized will most likely solve.

If possible, placing a solid, pink-filled shape behind the chevrons would also probably solve the issue by providing the color which Illustrator should use to anti-alias.

This is one of those things with patterns in AI that irks me... poor anti-aliasing.


My solution was to save as a PDF, open it in photoshop and save it as the raster image. I believe it was poor anti-aliasing as @Scott suggested, which Photoshop handles much better. Art optimized did not improve the issue. It's not an idea solution by any means, but it does work.

  • This only applies if it is an anti-aliasing artifact. There are a number of reasons that gaps appear in a pattern tile, such as the artwork not aligning perfectly with the bounding box. In fact, I just fought with Illustrator over this for a while and realised that my art was 1 in wide, the bounding box for the tile was 1 in wide, but the lines wouldn't disappear until my art was 1.0001 in wide (just a fraction of an inch larger). You won't really know until you expand the appearance. Then, if it wasn't the aliasing, you get to do all your work over again. :/
    – AVLien
    Commented Jun 6, 2019 at 21:51
  • @avlien i believe the issue arises when you the tiling pattern is scaled/ Due to that the clipping paths in the tile pattern have not rounded numbers. Say 999,42px x 999.42px This is causing the white gap to appear. They state with printing this wont appear. But it does show when you place the image in say Photoshop. Try setting the pattern in illustrator to 100% and scale the pattern itself in edit mode Commented Aug 5, 2020 at 22:32

The only fool-proof thing I have found is to use Art Optimized and export as TIFF. In a test that I did recently, only the TIF export format removed the lines.


I spent a lot of time trying to avoid this "white lines" problems.

I just find this and it works for me: http://fashionclassroom.com/blog/fixing-lines-in-illustrator-patterns

I find the solution for me in step 4: duplicating the shapes which are on the lines and they disappear!


Can be some rasterization error. Can't say about reasons for sure, BUT you always can export it with much higher resolution as you need and then downscale the raster to necessary size. I am sure lines will be gone.


It looks like you built a grid, then made the Chevron pattern on the grid.

To fix this, select your pink shapes all together by using the lasso tool or direct selection tool by holding shift while you click the shapes to add them in the selection.

Bring up the Pathfinder tool box, by going to > Window > Pathfinder. In the Pathfinder box > Merge.

This will get rid of the lines because it'll make it all one merged shape, not a series of smaller shapes.


In my experience using Illustrator CS6, the lines disapear when exporting the artwork to high quality pdf. So I stopped bothering with the little white lines.

  • Welcome to GD.SE, Christina! If you have any questions about how the site works, have a look at the help center or feel free to ping one of us in Graphic Design Chat once your reputation reaches 20. Keep contributing and enjoy the site!
    – Vicki
    Commented Jan 14, 2016 at 2:59

This worked for me: when exporting via File > Export > Export for Screens, under the 'Formats' section click on the gear icon and 'Anti-aliasing' and then from the pull down menu select 'Art Optimized (Supersampling)'.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.