2

So I'm trying to cut an image out of a solid background in Illustrator CS5 (Mac). I do this fairly often and my typical workflow is to:

  1. Place the image to be cut out on top of the background
  2. Group the image to be cut out if there are multiple pieces
  3. Select the top image and the background and use Minus Front on the Pathfinder

If the Minus Front doesn't work, I will sometimes use Divide instead. This usually works just fine and I can then delete the section that belong to the upper image, leaving me with the solid background with a shape cut out of it.

However, today I'm having an issue with the Pathfinder options messing with my paths. As you can see below, my shapes are perfectly symmetrical when I place them on the background. (The pink shape is the one I want to be cut out of the background).

shape to be cut out I then tried using the Minus Front tool from the Pathfinder, and these were my results:

messed up paths and corners! :(

As you can see, my shapes have been distorted and messed up after applying the Pathfinder option. I tried this with the Divide tool as well and got the exact same results. I've done this process with much more complex shapes in the past, so I know the Pathfinder can handle it, I'm just not sure what could be causing this.

I've also tried using "Expand Appearance" because that usually fixes my wonky problems with shapes in AI, but I had no luck there as well.

Does anyone have any idea why this shape might not be cooperating with the Pathfinder tool?

  • 1
    Can you post an image with all the anchors. This is very weird. Are you sure your Rounded Corner fx isn't effecting your shape? – Komental May 29 '14 at 21:23
  • I don't think this would be the reason for the issue you're seeing, but in general for your step 2, I would recommend Object > Compound Path > Make instead of grouping the objects. As @Komental said, I think it would be helpful to see a screenshot with everything selected so we can see your anchor points. – apex May 30 '14 at 16:31
  • Hey guys, thanks for the replies, however I'm having a bit of an issue... After I posted this I closed up Illustrator and now my file seems to be corrupted. I'm not able to get a screenshot of the object with the anchor points.. I will try to recreate it and try the Compound Path idea though. Thanks again for your input! – rhumbrecht May 30 '14 at 20:51
  • Also, I'm sure it's not a problem with rounded corners because I never applied rounded corners to the shapes, they're all freehanded with the Pen Tool. – rhumbrecht May 30 '14 at 20:56
  • Possible duplicate: graphicdesign.stackexchange.com/questions/16440/… – Scott Aug 24 '14 at 16:25
2

This may be too late for @rhumbrecht, but the Rounded Corners effect is more than likely the culprit.

The two key pieces of evidence are 1. the green background object (with which the foreground interacts) has rounded corners, and 2. although the rounded corners effect was not used on the foreground object, it has been used somewhere along the line, as seen in the appearance panel in the second screenshot, so I'm guessing it was the background object.

Remember in a Minus Front operation, that the front object is discarded. The foreground object becomes part of the background object, and inherits any effect applied to the background object.

If in doubt, always Show edges from the View menu. You'll see a discrepancy between the outline ('artwork' below) and the preview ('result').

enter image description here

What else might it be?

The other possibility is the Precision setting within Pathfinder > Options, but in this instance I couldn't mimic the problematic result no matter how imprecise I made the setting.

enter image description here

2

It's because the document was created in web mode. Create a new document in print mode, paste your objects in that new print document, and then try to use the pathfinder tool again.

(Just wasted an hour on this problem! Solved thanks to Distorted shape after using pathfinder (illustrator cc))

  • While I don't know if this was the cause of the OP's question … As stated in other answers, I think it's the pixel grid alignment; you can turn this off on an object-by-object basis or for all new objects using the transform palette's options and/or fly out menu respectively. Put simply, just disable pixel grid snap on all objects before performing the pathfinding operation. While your answer may fix the issue you describe, there is no need to use a print document just to avoid pixel snapping. I just thought it was important to clarify for others. – mhulse Oct 6 '16 at 16:23
1

I just ran into this problem. The cause for me was that when I created the document, I had selected "Align to pixel grid"in the Advanced section of the new document dialog. I'm not sure how to disable this after creating the document, but luckily for me it was a simple icon and creating a new document with pixel grid alignment off solved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.