5

When working with an image in photoshop which has a transparent background, pressing CTRL + A to select all, then CTRL + C to copy all, the selection only includes pixels that aren't fully transparent.

When working with an image which has a fully transparent border, the selection ends up being smaller than the image you selected (even though you used CTRL + A).

Is there a way to fix this?

  • 1
    Are you pasting into a new document or the same document? – JohnB Jun 12 '14 at 12:12
5

When you select something that has transparency and you try to copy and paste it into a new document, it acts the same as if you were to do image > trim.

If you try pasting it into a new document, even if you make it the same size as the previous one, it will paste in the center of the document (I'm sure this isn't what you want).

What I have done in the past is to paint a couple of pixels in all four corners of the image you are trying to copy. This will make sure the image is pasted back into place where you want it.

Another thing you can do, kind of as a shortcut is to make a new layer under the layer you want 'copied' and fill it with any color. Once you have the two layers, you can select both and "convert to smart object." This will convert both layers to a smart object. You can then double click on that smart layer and it will open a new window with your transparency image and background image. Delete the background image and save the new image as whatever you want!

  • Four years later, is there any other way to do this? Along with `Copy Merged" – xpy Mar 29 '18 at 9:21
  • @xpy, Unfortunately, I've been out of the photoshop game for some time now. I've only been using XD for "design" (basically prototyping only) and I develop from that. I'm sorry I don't have a better answer. – ntgCleaner Mar 29 '18 at 13:04
0

I am pretty sure when you select pixels less than 50% alpha photoshop does not include the dashed lines to indicate it is selected (but it is infact SELECTED)

there is no reason to select transparency since its just empty spaces

only way to keep it or have it moved with your layer is by maybe using smart object

0

Instead of using Ctrl+C, use Shift+Ctrl+C ("Copy Merged"). This preserves the size of the layer and the transparency. (But you MUST turn off all other layers first, or they'll be copied too.)

  • 1
    Not in Photoshop CSS. Transparent pixels are trimmed. – Scott Simpson Jul 22 '16 at 21:06
0

Very old question I know.... but....

Duplicate

Don't "copy"!

Yes, I realize that means you can't easily hit 2 shortcuts.. but if retaining the canvas dimensions is what you need, then "copy" is not what you need.

  • Control/Rick Click the layer in the Layers Panel and choose Duplicate Layer (or group) from the contextual menu

  • You can target the active document, another document, or a new document within the pop up which will appear.

  • Add the Option/Alt key to the Control/Rick Click to bypass the pop up if desired.

For duplicating within the active document, simply hold the Option/Alt key down and drag the layer you want to duplicate in the Layers Panel.

Duplicating, unlike "copy", honors the layer bounds, in other words.... the canvas size, not simply the pixels present on the layer.

  • Also cmd+J do duplicate the layer within the active document – Luciano May 23 at 14:30
-1

"Paste in Place" (Ctrl + Shift + V) will preserve the positioning if you're copying from a similarly-sized document.

What's actually on the clipboard will not include the fully transparent pixels however. If you're trying to get it into a new document, simply copying and selecting File > New will suggest the trimmed document size; copying it into another application will have only the trimmed data. You'll have to resort to exporting the image to preserve the larger canvas when exporting to another application.

  • Welcome! Can you please explain better? Can you for example add an screenshot showing what to do to solve the given issue? Please be specific! An one liner as answer is i.e. not a valid answer, it can not be it usually. – Mensch May 21 at 13:07
  • Even apart from @Kurt's correct comment that a one-liner is typically too short to be super-clear and useful, in this case also the OP's question was very clearly about the selection and copying side of the equation - they want to know how to include transparent pixels in the initial selection set so that this data is included in the copy-paste, whereas your answer boils down to "paste works"... perhaps you could edit your answer to give more detail that will help OP get the data they need into the clipboard so that paste will also work for them! – GerardFalla May 21 at 18:25
  • I certainly shall, though I'm away from my graphics rig right now. I'll update it when I get home :) – Chris Connett May 22 at 15:10
-3

My solution is to:

  • save the image layer as a PNG
  • open the PNG in Paint.net
  • perform all the copying and pasting you want
  • save the completed work
  • load work in Photoshop

Because Paint.net understands a pixel can be 00000000.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.