I have a shape, say, a rectangle and it has a fill color. I want to add text on top of that shape, but when I click with the text tool on top of the rectangle, the shape will lose its fill and the shape has turned into some "text bounding box".

I don't want this, I want the shape to stay the way it is and I want the text element on top of it. So far I've solved it by adding the text element outside the shape and then dragging it on top of it, but this is a frustrating step which I hope here to get a solution for how to avoid.

Does anyone know how I can disable this "transform shape to bounding box" feature?

1 Answer 1


You accidentally activated the Area Type Tool. This happens when you click an object with the type tool at certain locations—anchors iirc.

The regular type tool will give you a text cursor with a rectangular dotted border. If you hover over shapes, you will see the outline change to a circular one. That's to tell you that clicking there will activate the Area Type Tool.

An easy way to prevent mis-clicking altogether is to lock your object: select it and choose Object > Lock > Selection or Control/Option+2.

  • Wow, thanks! Never noticed before that the tool pointer changed, that should help me in the future with avoiding mis-clicking! Jun 23, 2014 at 9:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.