4

I have an inDesign document in which certain fonts don't work (size equal to zero for PC fonts). Is there a way to have these fonts automatically replaced by other fonts of my choice? If so, can I also choose some settings such as letter-spacing and size in order for the new fonts to resemble the most the missing ones?

  • Are you talking about other than going into the Find Font menu? – Lauren-Reinstate-Monica-Ipsum Jun 24 '14 at 9:58
  • Well this menu shows all missing fonts. I can pick the first one and choose a replacement font, but then if I pick the second one and choose yet another replacement font, inDesign applies this newly selected replacement font for the first one as well. I can't select one replacement font for each missing font. Also, I can't apply custom font settings. So if my replacement font is tighter than the missing one, I can't correct that with some letter-spacing for instance. Or am I missing something? – drake035 Jun 24 '14 at 10:58
  • "I can't select one replacement font for each missing font" sounds like something is wrong with your copy of InDesign. You're supposed to be able to select your choice of replacement fonts for each missing font. If I have Times and Helvetica missing, I should be able to substitute Adobe Garamond for Times and Optima for Helvetica. When I select Optima, Times shouldn't change from Garamond to Optima randomly. You should toss your prefs and/or reinstall first. – Lauren-Reinstate-Monica-Ipsum Jun 24 '14 at 11:19
  • 2
    If I understood you correctly, the Find font feature does exactly what you want. This is how you use it though: 1. Choose a missing font from the Font information section. 2. Below choose the replacing font. 3. Click Change all button. ––– Repeat these steps for each missing font. When you're done, press the done button... ––– I would then use Paragraph styles to edit the tracking settings. – Joonas Jun 24 '14 at 13:29
  • 1
    You should be able to take each missing font (Univers45, Univers55, Univers56) and replace it with something else (Helvetica45, Helvetica55, Helvetica56) without any given font interfering with any other font. There simply should not be any crossover. Either you're doing something wrong or you have a problem with your copy of InDesign. – Lauren-Reinstate-Monica-Ipsum Jun 24 '14 at 16:48
10

The simplest and most direct way to do this is by using Type > Find Font.... Highlight the font that doesn't work and choose the replacement. If appropriate, check the "Redefine Style When Changing All" box. Click Change All.

For a little more finesse, use the format tools in the Find/Change dialog. Don't type anything into the Find or Change to text fields. The format tools will allow you to specify very narrowly which font, point size, Character and/or Paragraph Style to target, with a similarly exact replacement.

0

Just as a little follow on to this 0kb issue that happens a lot in production design (and has for many years). It occurs when working with clients/ Project Managers running on Windows.

Essentially when zipping files between the two operating systems (often from a shared server location) the compression strips the file size to 0KB. For example, after finishing a lovely new design for a flyer and then pass along the uncompressed collect to the centralised server location, and the Windows user then zips it and emails on, then the file size can be reduced to 0.

"Find font" would be the best solution but finding and installing the same font/ typeface on your machine should automatically update your document without having any need to do any additional work. If you got to "Find Font" it will say exactly what is missing and then you just need to do a bit of digging to source it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.