2

I can't insert umlauts or a sharp s in Acrobat after I created the form with InDesign CS6.

Does anyone a similar problem / can help me with this? I suppose it has to do something with UTF-8 encoding but I have no idea where to look at. I'd be thankful for any tips with Acrobat or InDesign


Edit:

Alright, I found a (not so great) solution. Adobe Acrobat Pro -> Tools -> Forms -> Edit -> double click the field -> Appearance -> change font to Tahoma or similar. But is there a way to adjust that in InDesign?

  • 1
    Are you asking about inserting diacritics in text being typed into the form fields? – Alan Gilbertson Jun 30 '14 at 18:37
  • Thanks for the comment, haven't seen it. Yes, I'm asking for inserting diacritics from user-side when the enduser is typing something like Straße or Bärbel because it's only showing characters like a rectangle. – nihilistenhymne Jun 19 '15 at 16:22
  • 1
    I’ve never had any trouble with this, but that is perhaps because I’ve always (by accident) had all the special characters required present elsewhere in the document. Have you (a) checked that the necessary glyphs (ß, ä, etc.) are available in the font you’re using, and (b) tried setting the PDF Export Options → Advanced → Subset fonts when percent of characters used is less than field to 0%? That will force InDesign to embed the entire font (not just glyphs used in the document) in the PDF file. Note that this will increase the size of the PDF file, possibly quite radically. – Janus Bahs Jacquet Sep 15 '15 at 16:30
  • @JanusBahsJacquet Thanks for the comment! Unfortunately I can't get into any advanced options when I'm exporting this as an Interactive PDF..I'm working on CS6. Can you do that in InDesign CC? – nihilistenhymne Sep 16 '15 at 16:07
  • Oh, of course! That was me being silly and forgetting that the Interactive PDF export dialog box is different from the Print PDF export dialog box. No, that wouldn’t work for an Interactive PDF (which is odd, really, because surely that’s when you’d really need it, as evidenced by your question here). – Janus Bahs Jacquet Sep 16 '15 at 16:09
1

The easiest thing to do is to add umlaut-ed characters and the scharfes s to your document while creating it in InDesign. Many fonts already support these characters - access them in the Glyphs palette (Alt-shift-F11) - I use this so much it's permanently docked in my workspace!

  • Hello Dianne, welcome to GD.SE and thanks for your answer. If you have any questions, please see the help center or ping one of us in chat once your reputation is sufficient (20). Keep contributing and enjoy the site! – Zach Saucier Mar 18 '15 at 16:48
0

...Or, simply open keyboard viewer in your languages pull-own menu.Always best to create a style sheet, and use it when creating the original document.

Trying to fix these with the text tool in a .pdf file can be a nightmare. If you have the original text document, just go back and insert the umlaut where needed and then save the document again, a .pdf format.

  • What does any of that have to do with this question, which is about entering text in form fields in a PDF file? – Janus Bahs Jacquet Sep 15 '15 at 16:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.