7

I'm using Illustrator CC 2014 and have a radial gradient that looks smooth in edit, but gets really weird bands when I export or Save to Web (any format, all settings).

Here's how it looks in Illustrators artboard (just the top):

enter image description here

And here's how it looks after export!?

enter image description here

Notice the two light bands? How do I stop this?

  • 2
    Is your Illustrator document an RGB or CMYK document? – Scott Jul 7 '14 at 4:04
  • Banding is related to the number of colors you are writing. But the fact that two of the bands are lighter than they should be appears to be due to a bug of some kind in your writer. – Glenn Randers-Pehrson Jul 7 '14 at 13:22
  • That's very bizarre (it doesn't look like posterization due to limited colors). Are you sure you don't have some art there you're not aware of that might be rendering during the export? Have you tried saving a copy, deleting all layers except this one? Or recreating this shape & fill from scratch in a fresh document? – Rob Craig Jul 8 '14 at 5:33
  • 1
    Along the lines of @RobCraig, maybe try pressing Ctrl Y to change viewing modes, and check that area for any extra lines that may represent additional art that you may not mean to have. Ctrl Y will also change your view back. – apex Jul 8 '14 at 22:32
3

You can also try adding a grain on top of the gradient- it will kind of simulate PS's gradient dither. Effects > Texture > Grain. It's a raster effect so not optimal, but it should help.

| improve this answer | |
2

increase colors in save for web setting

In illustrator save for web settings increase no of colors to get bands removed.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.