2

I am trying to copy & 'paste in place' layers from Illustrator into Photoshop, however they never align correctly.

I have checked artboard and canvas size are the same and also same color mode. Still it will not align.

Can anyone offer advice? How can I check all transparency is off (this may be the problem). I am a complete novise to illustrator and Photoshop so I really don't know much about it. Always a learning curve!

3 Answers 3

5

As far as I'm aware there is no correlation between position in Illustrator and position in Photoshop. If copying from AI, it always pastes to the center of the canvas in Photoshop.

I may be mistaken though.

3
  • this could be scripted tough.
    – joojaa
    Jul 16, 2014 at 9:54
  • Thanks Scott. You may be right, it centered everything I wanted to paste inplace. Thanks joojaa - i read that somewhere - but I have no idea how to script let alone do basic stuff! Cheers!
    – Jim
    Jul 16, 2014 at 17:16
  • @Jim you can't disable the centering. Tim's suggestion of the empty rectangle somewhat works, but can be an issue in itself. If you dram a no-fill, no-stroke rectangle in AI to match your artboard size (which matches your .psd canvas size) it will paste in the center and line up at the edges. Of course, this makes that smart object layer the size of the entire Photoshop canvas as well.
    – Scott
    Jul 16, 2014 at 17:22
3

workaround: use a transparent rectangle with the size of your artboard.

not perfect but does the job

3
  • Thanks Tim. I tried what you suggested but it did not work. It pasted to the centre of the canvas. Can I turn off this 'centering'? Can you suggest a way that I can make all sublayers into individual Top Level Layers? Thanks for your help!
    – Jim
    Jul 16, 2014 at 17:14
  • I am not sure what you mean. if your illustrator object is the same size as your photoshop canvas it should align
    – tim human
    Jul 21, 2014 at 13:06
  • 1
    Hi Tim. You are correct. I realised that the illustrator objects are not the same size as the canvas. The layer is a 'world map', but all the sublayers are the individual countries and thay are not the same size as the top level layer. I don't think there is anything i can do. Someone suggested opening in Fireworks and saving as PSD, but I get the dreaded 'internal error' message when opening .ai in Fireworks. Looks like a long process of copy paste and manually place! Thanks for all your help!
    – Jim
    Jul 22, 2014 at 15:31
-1

Here's a workaround for dat'ass.. 1. in your Ai document, create a 1 point white stroked box the same size as your artboard. 2. center the invisible box to the artboard and copy entire contents 3. create a new PS document (same size/res) as your Ai file 4. paste your artwork/element in place (SFHT+CMMD+V)

BAM!!!...now your artwork will smack down in the same spot as your original Ai file. Now any vector tweaks can be done in synch with your PS file. (be sure to remove white stroke after every paste-in)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.