6

Is there a way to lock the zoom and the scroll bars in Krita so that they do not jump around, changing position and magnification, when I am not using the magnifying tool?

I am using a wacom tablet with Ubuntu 14.04 and the latest version of Krita.

The issue is that often I will touch the empty grey space behind the image and Krita will do one of 4 things:

  • change the zoom (ex: jump to 100% if I was at 50%)
  • change the actual pixel size of my page (ex: 800 x 800 -> 2146 x 1049 or some random px)

  • nothing (which is what I would hope for)

  • or, worst of all, Krita will jump way over to the side of the page so that my document is no longer in view. I will then move my mouse to the scroll bar at the bottom to move it back, but doing this will cause the vertical scroll bar to follow my mouse to the bottom and scroll all the way down (now a sliver of my doc is at the top in the center). I will then try to correct the view with the vertical scroll bar, but doing this will drag the horizontal bottom bar all the way to the right! This happens 5-10 times in a row until suddenly it stops.

I don't know if it is a bug, an incompatibility with wacom or ubuntu, or if it is just the way Krita is supposed to work. I also disable my touchpad when using wacom so it is not that.

Any suggestions?

  • Still searching for a real fix, but in case anyone else has this problem, I found that pressing TAB will center the view to your doc again. You then need to click on the doc itself - if you try going over to the side tool boxes before you click your doc, it will scroll out of control again. – Chris Marie Jul 16 '14 at 4:43
  • What do you even mean? Scroll bars and zoom jumping around randomly? It doesn't do that... Didn't do that back in 2014 either. This was probably an old bug, it's not still doing this to you is it? (You have downloaded the latest version right?) Krita should work best on linux (it was originally only available on linux, Windows version is a relatively new thing), and has no compatibility issues with wacom. It was definitely a bug. I've used it quite a bit since early 2014, never did this to me. – Cestarian Feb 16 '16 at 23:51
2

I was having this same problem.. I'm a complete amateur, but here's what I did:

  1. Top menu - go to Settings
  2. Canvas Input Settings
  3. Click on Zoom Settings - this will open a small sub-menu of shortcuts. Look for something like "mouse scroll zoom in" and "mouse scroll zoom out" - if you right click on these, the option will appear to disable the shortcut.

This solved the problem for me, hope it helps!

  • Hello Estelle, welcome to GDSE and thanks for your answer. If you have any questions, please see the tour or the help center or ping one of us in the Graphic Design Chat once your reputation is sufficient (20). Keep contributing and enjoy the site! – Vincent Feb 23 '18 at 9:44
0

You can easily verify this by zooming '1:1' (keyboard shortcut '1') this set the zoom correction factor to match the current monitor resolution (you draw by resolution of monitor - not graphic tablet features).

You can lock this with the lock icon (from grids).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.