39

I realize there are a ton of questions like this, but they are all way overcomplicated for what I am trying to do.

What I want to do is very simple. I want the background of my image completely transparent, and the foreground completely opaque. My background is white while my foreground is a pale blue and gold. Whenever I use color to alpha I end up with the foreground being semi-transparent.

How do I make the background transparent without changing the transparency of the foreground?

  • it is better to repace this way: graphicdesign.stackexchange.com/q/21685 . – qdinar Mar 23 '19 at 3:50
  • @qdinar Why is it better? What you link is Photoshop and not GIMP, GIMP's Color to Alpha works perfectly. – Csaba Toth Mar 4 at 22:14
  • @CsabaToth maybe i had a case with white areas in the foreground which i wanted not to make transparent, but i wanted transparency in the border, to not have white borders when selection is pasted onto other background. – qdinar Mar 5 at 6:45
41

Whenever we choose to change a color to transparent with the Layer > Transparency> Color to alpha tool we will also introduce semi-transparency of colors different to the selected. Below this is shown for making white in the background transparent:

enter image description here

In case this is not wanted we need to select only a single colored area for transparency. This can be done with the select by color tool enter image description here.

  • Make the threshold of selection low to zero to select only a single color.
  • Feather the selection for a smoother transition.
  • Add a transparent layer if not yet present (Layers > Transparency > Add Alpha Channel)
  • Clear (Edit > Clear or Del) the selected color to make it transparent:

enter image description here

| improve this answer | |
  • 1
    I coudn't realize how to "Make the threshold of selection low" – Shirley Temple Oct 1 '17 at 17:52
  • 2
    @ShirleyTemple it is what the tools option for Gimp "select by color" lets you choose. The higher the threshold the more similar colors are included. – Takkat Oct 1 '17 at 19:25
  • That still leaves a white halo around, instead of replacing the white with transparency. – Flimm Jan 21 '19 at 16:38
  • @Flimm you may have to feather the selection a bit more to get rid of any anti-aliasing white that may still be there. – Takkat Jan 21 '19 at 17:15
0

Use the "Select by Color Tool". Not the "Color Picker Tool". Be sure to Layer-Transparency-Add Alpha Channel. Try a higher threshold setting like 29 instead of 0 of the "Select by Color Tool". Then Press Delete. No Halo :)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.