4

The Inkscape FAQ states:

In fact, if you use a path as the clipping object, you can actually edit the clip path without having to Release it. First select the clipped object, then choose the Node Editing Tool. Your clip path will be outlined Green, with the normal path editing nodes visible.

Well, I have clipped a bitmap with a path. Yet, when I select the clipped object with the tool "Edit paths by nodes (F2)", then I get no path editing nodes. There is just a dotted outline around the object.

I am using Inkscape 0.48.5 on Windows 7 x64.

Am I doing something wrong? Is my version of Inkscape not capable of doing that? Something else?

Screenshot illustrating the issue

  • Jesus, what resolution is that?! – SaturnsEye Jul 29 '14 at 10:48
4

You can do this, but you have to enable "Show clipping path(s) of selected object(s)"

Imgur

For smaller screens :

Imgur

Also, when you move the image, the clip path doesn't move with the image, so things like this can happen:

Imgur

  • 2
    That's it! At least in v0.91pre1_64bit, I cannot reproduce the image-move-problem, fortunately. – feklee Aug 26 '14 at 14:12
  • 1
    I'm using 0.92.1 on Kubuntu but I don't see that setting. Instead I have a global setting (which was enabled) that says to delete the clipping object when the clip is set. Unsetting doesn't show me the object even, and there's definitely no green path either. – pbhj Mar 17 '17 at 0:16
2

You can't edit the clipping path directly. Ordinariy, you will have to unset the clipping path (select clipped object, object->clip->unset), modify the path, and set the clipping again.

As that may be unsuitable for most cases, one possible work around is to create a clone of the clipping path (edit->clone->create clone), and set the clonned path as the clipping. Then, you just have to edit the original path to see the live modification of the clipped object.

  • So the FAQ is wrong? It says: "you can actually edit the clip path without having to Release it" – feklee Jul 30 '14 at 16:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.